Bug 443329 - dependecy problem freenx-server from updates-testing
dependecy problem freenx-server from updates-testing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 14:52 EDT by Reindl Harald
Modified: 2008-07-29 07:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.2-8.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-10 09:56:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-04-20 14:52:37 EDT
****     Missing Dependency: /usr/share/nx is needed by package freenx-server
**** Checking for dep problems  : freenx - 0.7.1-3.fc8.i386

There goes something wrong
I like to test this and hope in future-versions the bug that closing the client
from nx-machine will be able to save the session instead starting the nx-client
on the remote-machine will go away :-)
Comment 1 Fedora Update System 2008-04-23 12:43:37 EDT
freenx-server-0.7.2-8.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-04-23 12:43:44 EDT
freenx-server-0.7.2-8.fc7 has been submitted as an update for Fedora 7
Comment 3 Axel Thimm 2008-04-24 04:37:46 EDT
freenx has been split into freenx-server and freenx-client. Most open bugs for
freenx addressed parts of the current freenx-server package. See also bug #438660.

freenx-server is currently in testing repos. Please give it a try as it will
soon replace the freenx package.
Comment 4 Reindl Harald 2008-04-26 06:50:32 EDT
And thats the point - Its useless to put it to updates-testing as long as the
bug " Missing Dependency: /usr/share/nx is needed by package freenx-server"
still exists.

Read my first bug report again, it is not fine when you use updates-testing the
whole time and there are missing dependencies

Comment 5 Fedora Update System 2008-04-29 16:56:45 EDT
freenx-server-0.7.2-8.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-3368
Comment 6 Fedora Update System 2008-04-30 03:15:39 EDT
freenx-server-0.7.2-8.fc9 has been submitted as an update for Fedora 9
Comment 7 Axel Thimm 2008-04-30 03:40:17 EDT
(In reply to comment #4)
> And thats the point - Its useless to put it to updates-testing as long as the
> bug " Missing Dependency: /usr/share/nx is needed by package freenx-server"
> still exists.
> 
> Read my first bug report again, it is not fine when you use updates-testing the
> whole time and there are missing dependencies

This was certainly not on purpose, and in fact that's why we have a testing repo
in the first place - to discover such bugs. The split of the packages and the
build happened two weeks before you submitted this bug. It just takes a while
until the whole machinery processes an update, especially when there is
additional administrative work going on behind the scenes (like the F9 branching).

I fixed the bug as soon as you filed it (already in comment #1) and you can see
the time it takes to propagate. We're not yet at light speed ;)
Comment 8 Reindl Harald 2008-04-30 06:57:17 EDT
Thank you!
The new version from updates-testing works and is the first since F8-Release
where closing the client from nomachine requests terminate/suspend the session
instead of starting the nomachine-client in the remote-session!

I have wonderd only why there was an package with unresolveable dependencies
because this let me think the package was never tested - packages built on koji
are never the same time in updates-testing, kernels etc. are long before they
will be moved to updates-testing availabe over koji-build-server and many of
them never will go to any yum-server :-)
Comment 9 Axel Thimm 2008-04-30 07:30:51 EDT
(In reply to comment #8)
> I have wonderd only why there was an package with unresolveable dependencies
> because this let me think the package was never tested - packages built on koji
> are never the same time in updates-testing, kernels etc. are long before they
> will be moved to updates-testing availabe over koji-build-server and many of
> them never will go to any yum-server :-)

There is also the scenario which happened in this case that the dependency
existed and vanished during an update of a dependent package. There is no
safe-guard in koji or elsewhere yet to prevent this or give an alarm. Usually
the packager alarms the other packagers, in this case the faulty packager
forgetting to alarm the others was me myself (the nx package). So I get to blame
me. ;)

Comment 10 Fedora Update System 2008-05-10 09:56:45 EDT
freenx-server-0.7.2-8.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-05-13 11:29:49 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Reindl Harald 2008-05-16 06:17:31 EDT
For i386 all works ok now
Fedora 9 x86_64 seems to have the same problem

Package freenx is obsoleted by freenx-server, trying to install
freenx-server-0.7.2-8.fc9.x86_64 instead
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket freenx-server.x86_64 0:0.7.2-8.fc9 gesetzt um aktualisiert zu werden
filelists.xml.gz                                                 25 kB 00:00
filelists.sqlite.bz2                                     |  12 MB     00:21
filelists.xml.gz                                                 36 kB 00:00
filelists.sqlite.bz2                                     | 168 kB     00:00
filelists.sqlite.bz2                                     | 593 kB     00:00
filelists.xml.gz                                                 864 B 00:00
--> Verarbeite Abhängigkeiten: /usr/lib64/nx für Paket: freenx-server
--> Verarbeite Abhängigkeiten: nx für Paket: freenx-server
--> Führe Transaktionsprüfung aus
---> Paket freenx-server.x86_64 0:0.7.2-8.fc9 gesetzt um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: /usr/lib64/nx für Paket: freenx-server
---> Paket nx.i386 0:3.2.0-27.fc9 gesetzt um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: libXpm.so.4 für Paket: nx
--> Verarbeite Abhängigkeiten: libXtst.so.6 für Paket: nx
--> Führe Transaktionsprüfung aus
---> Paket freenx-server.x86_64 0:0.7.2-8.fc9 gesetzt um aktualisiert zu werden
--> Verarbeite Abhängigkeiten: /usr/lib64/nx für Paket: freenx-server
---> Paket libXpm.i386 0:3.5.7-4.fc9 gesetzt um aktualisiert zu werden
---> Paket libXtst.i386 0:1.0.3-3.fc9 gesetzt um aktualisiert zu werden
--> Abhängigkeitsauflösung beendet
freenx-server-0.7.2-8.fc9.x86_64 von updates hat Abhängigkeitsauflöse-Probleme
  --> Fehlende Abhängigkeit: /usr/lib64/nx wird benötigt von Paket
freenx-server-0.7.2-8.fc9.x86_64 (updates)
Fehler: Fehlende Abhängigkeit: /usr/lib64/nx wird benötigt von Paket
freenx-server-0.7.2-8.fc9.x86_64 (updates)
[root@srv-rhsoft ~]#    
Comment 13 Fedora Update System 2008-07-26 02:05:01 EDT
freenx-server-0.7.2-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Brian Morrison 2008-07-29 07:35:44 EDT
Attempting to install the x86_64 packages for freenx-server and nx results in a
"Nothing to do" error, no x86_64 packages available.

I can't find any newer packages in Koji either.

"yum install nx freenx-server" will only install nx as there is no
freenx-server.i386 package in the repos.

Don't understand what is happening here!

Note You need to log in before you can comment on or make changes to this bug.