Bug 432271 - konqueror cannot connect to bugzilla - SSL negotiation failed.
konqueror cannot connect to bugzilla - SSL negotiation failed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
: 436974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 14:33 EST by Orion Poplawski
Modified: 2008-04-02 09:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.3.4-10.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 09:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of konqueror to mail.google.com (2.76 MB, application/octet-stream)
2008-04-01 15:10 EDT, Gerald Cox
no flags Details
strace of konqueror to mail.google.com (2.81 MB, application/octet-stream)
2008-04-01 15:31 EDT, Gerald Cox
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 155564 None None None Never

  None (edit)
Description Orion Poplawski 2008-02-10 14:33:14 EST
Description of problem:

Built a livecd from current devel.  Try to connect to
https://bugzilla.redhat.com/ in konqueror and I get:

An error occurred while loading https://bugzilla.redhat.com/:
Could not connect to host bugzilla.redhat.com: SSL negotiation failed.

Firefox connects fine.

Version-Release number of selected component (if applicable):
kdebase-4.0.1-3.fc9.i386

How reproducible:
everytime.
Comment 1 Rex Dieter 2008-02-12 17:01:13 EST
Ugh, that's supposed to be fixed in kdelibs-4.0.1-1+ builds, see also bug #429846
(or at least one other openssl-related issue).

fwiw, bugzilla.redhat.com worksforme.
Comment 2 Rex Dieter 2008-02-12 17:02:33 EST
Does konq -> Settings -> Configure Konqueror -> WebBrowsing -> Crypto -> OpenSSL
tab, "Test" button report success or faiilure?
Comment 3 Gerald Cox 2008-02-24 14:07:48 EST
"Test" button reports success.  Issue still exists in:
kdebase-4.0.1-3.fc9.i386
kdelibs-4.0.1-6.fc9.i386

FWIW Firefox isn't working at all for me, and I'm just trying to get to work
using the Alpha distribution.  I'll look to see if a bug exists for that...
Comment 4 Orion Poplawski 2008-03-12 16:17:30 EDT
Test button works for me too.  Still cannot connect with kdebase-4.0.2-2.fc9,
just hangs forever.
Comment 5 Rex Dieter 2008-03-12 17:47:38 EDT
I (still) can't reproduce this.  WORKSFORME.
Comment 6 Gerald Cox 2008-03-12 19:47:02 EDT
Hummmmmmmm...I just tried again and it still isn't working...I have never been
able to get it to work with F9 Alpha, and I've been keeping up with updates on a
daily basis.  Rex, did you try http://mail.google.com?  When I try to connect to
that, I get:
An error occurred while loading http://mail.google.com:
Could not connect to host www.google.com: SSL negotiation failed.

and when I try bugzilla, it just hangs...

Firefox, otoh is working fine now... early on had some issues, but those have
been corrected via updates.  I'm wondering if there is any correlation with the
SSL problems with kopete?  Just a thought...
Comment 7 Rex Dieter 2008-03-12 23:03:49 EDT
both bugzilla, gmail work for me.  wierd.
Comment 8 Gerald Cox 2008-03-12 23:26:38 EDT
Looks like this has been reported upstream and affects multiple distros:
https://bugs.kde.org/show_bug.cgi?id=155564

Same symptoms, possible tie in to the reported kopete issue.  Some folks don't
have the issue, but majority seem to have it.  Wonder if there is a hardware
dependency - I'm running AMD64 and having the issue.
Comment 9 Kevin Kofler 2008-03-13 06:10:02 EDT
Maybe an OpenSSL bug? I remember XChat being hit by similar "SSL negotiation 
fixed" errors and an OpenSSL patch fixed it, maybe the fix was not complete?
Comment 10 Kevin Kofler 2008-03-13 06:10:24 EDT
Oops, I mean "SSL negotiation failed" errors of course, not "fixed". ;-)
Comment 11 Gerald Cox 2008-03-26 23:14:41 EDT
Did a clean install of F9 Beta hoping that maybe something had gotten corrupted
during the install of the Alpha and a fresh install with beta would resolve. 
Same result:

An error occured while loading...
Could not connect to host www.google.com SSL negotiation failed 

Has anyone else done a fresh install from the beta DVD and gotten this to work?
Comment 12 Ngo Than 2008-03-31 06:16:44 EDT
i cannot reproduce with latest rawhide. it seems fixed in rawhide.
Comment 13 Orion Poplawski 2008-03-31 14:14:49 EDT
Still just hangs forever(?) for me on today's rawhide.
Comment 14 Orion Poplawski 2008-03-31 14:20:16 EDT
Here's some actual information from .xsession-errors:

konqueror(3809) LocalDomainUriFilter::filterUri:
KUrl("https://bugzilla.redhat.com/")
konqueror(3809) FixHostUriFilter::filterUri: FixHostUriFilter::filterUri: 
KUrl("https://b
ugzilla.redhat.com/")
konqueror(3809) KonqMainWindow::openFilteredUrl: url 
"https://bugzilla.redhat.com/"  filt
ered into  KUrl("https://bugzilla.redhat.com/")
konqueror(3809) KonqMainWindow::openUrl: KonqMainWindow::openUrl : url = '
KUrl("https://b
ugzilla.redhat.com/") '   mimeType=' ""  req=
"[typedUrl=https://bugzilla.redhat.com/ newT
abInFront]" ' view= QObject(0x0)
konqueror(3809) KonqMainWindow::openUrl: trying openView for 
KUrl("https://bugzilla.redha
t.com/")  (mimeType  "" )
konqueror(3809) KonqMainWindow::openUrl: Creating new konqrun for 
KUrl("https://bugzilla.
redhat.com/")  req.typedUrl= "https://bugzilla.redhat.com/"
konqueror(3809)/kparts KParts::BrowserRun::scanFile: BrowserRun::scanfile
KUrl("https://bu
gzilla.redhat.com/")
konqueror(3809)/kio (Slave) KIO::Slave::createSlave: createSlave ' "https" ' for
 "https:/
/bugzilla.redhat.com/"
konqueror(3809)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote:
Listening on
"local:/tmp/ksocket-orion/konquerorwy3809.slave-socket"
klauncher(3600)/kio (KLauncher) KLauncher::requestSlave: KLauncher: launching
new slave  "
kio_http"  with protocol= "https"  args= ("https",
"local:/tmp/ksocket-orion/klauncherMT36
00.slave-socket", "local:/tmp/ksocket-orion/konquerorwy3809.slave-socket")
kdeinit4: Got EXEC_NEW 'kio_http' from launcher.
kdeinit4: preparing to launch
klauncher(3600)/kio (KLauncher) KLauncher::processRequestReturn: "kio_http" (pid
4315) up
and running.
QSslSocket: cannot find ssl library: QLibrary::load_sys: Cannot load ssl
(libssl.so: cannot open shared object file: No such file or directory).
kio_http(4315)/kio (kioslave) KIO::SlaveBase::checkCachedAuthentication:
SlaveBase::checkCachedAuthInfo window =  52428801  url = 
"https://bugzilla.redhat.com/"
kded(3602)/kio (KPasswdServer) KPasswdServer::checkAuthInfo:
KPasswdServer::checkAuthInfo: User=  "" , WindowId =  52428801
kio_http(4315) HTTPProtocol::httpOpen: ============ Sending Header:
kio_http(4315) HTTPProtocol::httpOpen: "GET / HTTP/1.1"
kio_http(4315) HTTPProtocol::httpOpen: "Connection: Keep-Alive"
kio_http(4315) HTTPProtocol::httpOpen: "User-Agent: Mozilla/5.0 (compatible;
Konqueror/4.0; Linux) KHTML/4.0.3 (like Gecko) Fedora/4.0.3-1.fc9"
kio_http(4315) HTTPProtocol::httpOpen: "Accept: text/html, image/jpeg,
image/png, text/*, image/*, */*"
kio_http(4315) HTTPProtocol::httpOpen: "Accept-Encoding: x-gzip, x-deflate,
gzip, deflate"
kio_http(4315) HTTPProtocol::httpOpen: "Accept-Charset: utf-8, utf-8;q=0.5, *;q=0.5"
kio_http(4315) HTTPProtocol::httpOpen: "Accept-Language: en-US, en"
kio_http(4315) HTTPProtocol::httpOpen: "Host: bugzilla.redhat.com"
kio_http(4315)/kssl KIO::TCPSlaveBase::disconnectFromHost:
kio_http(4315)/kssl KIO::TCPSlaveBase::connectToHost: before connectToHost:
Socket error is  0 , Socket state is  0
kio_http(4315)/kssl KIO::TCPSlaveBase::connectToHost: after connectToHost:
Socket error is  0 , Socket state is  1
kio_http(4315)/kssl KIO::TCPSlaveBase::connectToHost: after waitForConnected:
Socket error is  0 , Socket state is  3 , waitForConnected returned  true
QSslSocket: cannot call unresolved function SSLv3_client_method
QSslSocket: cannot call unresolved function SSL_CTX_new
QSslSocket: cannot call unresolved function ERR_get_error
QSslSocket: cannot call unresolved function ERR_error_string
knotify(3634) KNotify::event: 29  ref= 0


Looks like it's failing to find the ssl library.

Comment 15 Rex Dieter 2008-03-31 14:54:57 EDT
Let's keep further comment/dialog upstream @
http://bugs.kde.org/155564
please.
Comment 16 Gerald Cox 2008-04-01 15:10:05 EDT
Created attachment 299948 [details]
strace of konqueror to mail.google.com 

Kevin...
Attaching results of:
strace konqueror 2
target url:  mail.google.com
Received following error messsage:
An error occurred while loading http://mail.google.com:
Could not connect to host www.google.com: SSL negotiation failed.
Comment 17 Gerald Cox 2008-04-01 15:31:07 EDT
Created attachment 299951 [details]
strace of konqueror to mail.google.com 

Correct log file...ignore previous.
Comment 18 Kevin Kofler 2008-04-01 15:40:18 EDT
Thanks for the log, unfortunately that doesn't enlighten us either. :-(

The KDE architecture is biting us there, all the SSL calls happen in the 
kio_http ioslave, so all Konqueror gets is the error message. :-( Back to the 
drawing board...
Comment 19 Orion Poplawski 2008-04-01 16:33:26 EDT
Discussion is moving forward in the upstream bug.  Look there...
Comment 20 Kevin Kofler 2008-04-01 22:33:29 EDT
From the upstream bugzilla:

------- Additional Comment #31 From Orion Poplawski 2008-04-01 22:32 -------  
I think it's a Qt issue.   
 
 qt-x11-opensource-src-4.3.4/src/network/qsslsocket_openssl_symbols.cpp:257: 
 
     QLibrary libssl(QLatin1String("ssl")); 
     if (!libssl.load()) { 
         // Cannot find libssl 
         qWarning("QSslSocket: cannot find ssl library: %s.", 
                  qPrintable(libssl.errorString())); 
         return false; 
     } 
 
 Seems like this needs to be libssl(QLatin1String("ssl"),SSL_VERSION) with 
SSL_VERSION = 7 in Fedora devel. 
 
 
 So it's asking QLibrary to load "libssl.so".
Comment 21 Kevin Kofler 2008-04-01 22:33:48 EDT
Thanks Orion, this looks fairly easy to patch.
Comment 22 Kevin Kofler 2008-04-01 23:44:59 EDT
Should be fixed in qt-4.3.4-10.fc9, please test.
http://koji.fedoraproject.org/koji/taskinfo?taskID=543345

This is also likely to fix the SSL-related errors with Kopete.
Comment 23 Ngo Than 2008-04-02 05:43:02 EDT
it's similar bug in kdelibs that we already fixed. Good work Orion, thanks.
Comment 24 Kevin Kofler 2008-04-02 09:49:48 EDT
Confirmed fixed, thanks to Gerald Cox.
Comment 25 Kevin Kofler 2008-04-02 09:56:05 EDT
*** Bug 436974 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.