Bug 432316 - skip-broken dependency that fails to skip
skip-broken dependency that fails to skip
Status: CLOSED DUPLICATE of bug 432143
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-11 03:59 EST by Andrew Farris
Modified: 2014-01-21 18:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-11 04:05:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
sysconf-firewall-skipbroken-fail-d9.txt (43.32 KB, text/plain)
2008-02-11 03:59 EST, Andrew Farris
no flags Details

  None (edit)
Description Andrew Farris 2008-02-11 03:59:19 EST
Description of problem:
The --skip-broken code fails to fix the dependency issue in the attached log and
continue with the install.  The update of system-config-firewall-tui and
system-config-firewall fail because the wrong version of usermode is the only
thing available, but both of these are not skipped (the -tui package has no
requires but is required by system-config-firewall which also requires usermode).

Skip broken should prevent both packages from stopping the update.

Version-Release number of selected component (if applicable):

---> Package system-config-firewall.noarch 0:1.2.3-1.fc9 set to be updated
Checking deps for system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'usermode', u'GE', (u'0', u'1.94.1', None)) as a requirement of
system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'system-config-firewall-tui', u'EQ', (u'0', u'1.2.3', u'1.fc9'))
as a requirement of system-config-firewall.noarch 0-1.2.3-1.fc9 - u
system-config-firewall-1.2.3-1.fc9.noarch requires: usermode >= 1.94.1
--> Processing Dependency: usermode >= 1.94.1 for package: system-config-firewall
Searching pkgSack for dep: usermode
Potential match for usermode from usermode-1.94-1.fc9.x86_64

system-config-firewall-1.2.3-1.fc9.noarch from development has depsolving problems
  --> Missing Dependency: usermode >= 1.94.1 is needed by package
system-config-firewall-1.2.3-1.fc9.noarch (development)
1:anjuta-2.2.0-4.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: libgbf-widgets-1.so.0()(64bit) is needed by package
1:anjuta-2.2.0-4.fc9.x86_64 (installed)
Running "postresolve" handler for "fedorakmod" plugin
Skip-broken round 1
--> Running transaction check
Checking deps for system-config-firewall-tui.noarch 0-1.2.2-1.fc9 - None
system-config-firewall-1.2.2-1.fc9.noarch requires: system-config-firewall-tui =
--> Processing Dependency: system-config-firewall-tui = 1.2.2-1.fc9 for package:
Potential Provider: system-config-firewall-tui.noarch 0:1.2.2-1.fc9
Mode is u for provider of system-config-firewall-tui = 1.2.2-1.fc9:
system-config-firewall-tui.noarch 0:1.2.2-1.fc9
Mode for pkg providing system-config-firewall-tui = 1.2.2-1.fc9: u
Error: No Package Matching  system-config-firewall
Comment 1 Andrew Farris 2008-02-11 03:59:19 EST
Created attachment 294543 [details]
Comment 2 Andrew Farris 2008-02-11 04:05:17 EST

*** This bug has been marked as a duplicate of 432143 ***

Note You need to log in before you can comment on or make changes to this bug.