Bug 432448 - No sound with Adobe Flash media due to missing alsa-libs.i386 deps
No sound with Adobe Flash media due to missing alsa-libs.i386 deps
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libflashsupport (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 22:03 EST by Keith G. Robertson-Turner
Modified: 2008-08-04 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 15:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 432241 None None None Never

  None (edit)
Description Keith G. Robertson-Turner 2008-02-11 22:03:39 EST
Description of problem:
nspluggin wrapper in conjunction with libflashsupport, and the Adobe Flash
plugin, won't produce any audio output without the i386 version of alsa-libs,
specifically /lib/libasound.so.2, which is not provided in the x86_64 repo.

Version-Release number of selected component (if applicable):
libflashsupport-000-0.1.svn20070904

How reproducible:
Always

1. yum -y install nspluginwrapper.{i386,x86_64} pulseaudio-libs.i386 libflashsupport
2. mozilla-plugin-config -i -g -v
3. launch Firefox and attempt to view Flash content
  
Actual results:
Video playback with no sound

Expected results:
Sound support

Additional info:
I discovered this by accident (a hunch), and could find no other info about this
anywhere, so presumably there will be a lot of people out there interested in
this solution (install alsa-libs.i386).

I'm not sure that this is supposed to be the correct behaviour, but it works
regardless.
Comment 1 Warren Togami 2008-02-11 22:18:30 EST
Hey Lennart,

Do you know if libflashsupport.i386 actually must have alsa-lib.i386 installed
in order to work?  It has no library link dependency on it so it isn't
explicitly pulled in.
Comment 2 Keith G. Robertson-Turner 2008-02-11 23:00:23 EST
Actually I only have libflashsupport.x86_64, the i386 version wasn't pulled in
as a dep either (is it's needed on an AMD64 system?).

Perhaps this dependency on alsa-lib.i386 is hard-coded into Adobe's
libflashplayer.so? That might explain the problem.
Comment 3 Warren Togami 2008-02-19 10:21:38 EST
Each arch of libflashsupport needs to Require its corresponding arch of
alsa-lib.  On the surface this seems like it would be simple, but it really isn't. 

Requires: alsa-lib

This alone is not enough to guarantee that you will actually get both archs,
because one arch alone will satisfy the dependency unfortunately. 
Comment 4 Warren Togami 2008-08-04 15:02:37 EDT
It was deemed impossible to pull this into a default install due to release engineering policy, and anyhow in Flash 10 you do not even need libflashsupport anymore.  Closing CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.