Bug 432571 - RPM install scriptlet buggy...
RPM install scriptlet buggy...
Status: CLOSED DUPLICATE of bug 433063
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 18:13 EST by Valdis Kletnieks
Modified: 2008-02-18 01:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 12:27:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2008-02-12 18:13:48 EST
Description of problem:
During a 'yum update', the following error got reported:

  Updating  : beagle                       ##################### [101/421] 
/usr/src/redhat/tmp/rpm-tmp.66648: line 11: cd:
/usr/lib64/xulrunner-1.9pre/extensions: No such file or directory

I'm looking at the xulrunner RPM, and not seeing where it either contains the
'extensions' directory nor where the install scriptlets for xulrunner create it,
so relying on the value of $ffdir/extensions existing seems a bit hazardous.

And the unprotected 'cd', when it fails, also explains why I have a directory
called '/{fda00e13-8c62-4f63-9d19-d168115b11ca}' with beagle crap in it in the
'/' root directory.

Version-Release number of selected component (if applicable):
beagle-0.3.3-1.fc9.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valdis Kletnieks 2008-02-12 18:19:00 EST
% rpm -qlp xulrunner-1.9-0.beta2.18.nightly20080210.fc9.x86_64.rpm | grep exten
/etc/skel/.mozilla/extensions
/usr/lib64/mozilla/extensions
/usr/lib64/xulrunner-1.9pre/components/extensions.xpt
/usr/share/mozilla/extensions

while /etc/gre.d/gre.conf says GRE_PATH=/usr/lib64/xulrunner-1.9pre - so as far
as I can tell, xulrunner wants *ITS* path, and a separate
/usr/lib64/mozilla/extensions directory, and beagle is conflating the two...
Comment 2 Adel Gadllah 2008-02-17 12:27:12 EST

*** This bug has been marked as a duplicate of 433063 ***
Comment 3 Adel Gadllah 2008-02-17 12:53:19 EST
There are some problems with this tried to apply as is but the build failed
because nobody created the
$RPM_BUILD_ROOT%{_libdir}/xulrunner/extensions/%{firefox_app_id}/ 
A mkdir -p would fix this but looking further it seems that
%{_libdir}/xulrunner/ is versioned so just installing in there seems to be
incorrect (does firefox/xulrunner even look into this directory?). And nobody
seems to own this directory seems wrong too ...
Comment 4 Christopher Aillon 2008-02-18 01:40:56 EST
Sorry, it should have been
$RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{firefox_app_id}/

Note You need to log in before you can comment on or make changes to this bug.