Bug 433063 - update where beagle installs the browser extension
update where beagle installs the browser extension
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
: 431157 432571 433376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 16:57 EST by Christopher Aillon
Modified: 2008-02-23 07:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-23 07:37:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2008-02-15 16:57:35 EST
I'm not sure if the extension is arch dependent or not.  Sub datadir for libdir
below if it's arch dependent.  Untested.

Index: beagle.spec
===================================================================
RCS file: /cvs/extras/rpms/beagle/devel/beagle.spec,v
retrieving revision 1.119
diff -d -u -p -r1.119 beagle.spec
--- beagle.spec	13 Feb 2008 19:01:03 -0000	1.119
+++ beagle.spec	15 Feb 2008 21:15:17 -0000
@@ -55,12 +55,8 @@ Patch6: beagle-monodoc.patch
 ExcludeArch: s390 s390x sparc64 ppc64
 
 
-# Firefox location info, for the beagle firefox plugin
-%if "%{_libdir}" == "/usr/lib64"
-%define grefile /etc/gre.d/gre64.conf
-%else
-%define grefile /etc/gre.d/gre.conf
-%endif
+# Firefox APP ID, for the beagle firefox extension
+%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
 
 %description
 A general infrastructure for making your data easy to find. 
@@ -125,7 +121,7 @@ mkdir -p $RPM_BUILD_ROOT/var/cache/beagl
 rm -f $RPM_BUILD_ROOT/etc/xdg/autostart/beagle-search-autostart.desktop
 
 # TODO: Isn't there a better place to install this?
-install -m 644 firefox-extension/beagle.xpi $RPM_BUILD_ROOT%{_libdir}/beagle/
+install -m 644 firefox-extension/beagle.xpi
$RPM_BUILD_ROOT%{_libdir}/xulrunner/extensions/%{firefox_app_id}
 
 desktop-file-install --vendor gnome --delete-original		\
   --dir $RPM_BUILD_ROOT%{_datadir}/applications			\
@@ -179,23 +175,6 @@ if [ -f %{_libdir}/beagle/beagle-plugin-
   rm -rf  %{_libdir}/beagle/beagle-plugin-path 
 fi
 
-# install the firefox extension
-if [ -f %{grefile} ] ; then
-  ffdir=$(cat %{grefile} | awk '/GRE_PATH/ { split($0,p,"="); print p[2] }')
-
-  cd $ffdir/extensions
-  mkdir beagle-extension
-  unzip -q -d beagle-extension %{_libdir}/beagle/beagle.xpi
-  id=`grep em:id beagle-extension/install.rdf | head -1 | sed -e 's/^ *//' -e
"s/<[^<]*>//g" | tr -d "\n\r"`
-  if [ -e "$id" ]; then
-    rm -rf beagle-extension
-  else
-    mv beagle-extension "$id"
-  fi
-
-  echo "$ffdir/extensions/$id" >  %{_libdir}/beagle/beagle-plugin-path
-fi
-
 %post devel
 if [ -x %{_bindir}/monodoc ]; then
   %{_bindir}/monodoc --make-index > /dev/null
@@ -209,38 +188,6 @@ fi
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%triggerin -- firefox
-if [ -f %{_libdir}/beagle/beagle-plugin-path ]; then
-  old=`cat %{_libdir}/beagle/beagle-plugin-path`
-  rm -rf $old
-  rm -rf  %{_libdir}/beagle/beagle-plugin-path
-fi
-
-# install the firefox extension
-if [ -f %{grefile} ] ; then
-  ffdir=$(cat %{grefile} | awk '/GRE_PATH/ { split($0,p,"="); print p[2] }')
-
-  cd $ffdir/extensions
-  mkdir beagle-extension
-  unzip -q -d beagle-extension %{_libdir}/beagle/beagle.xpi
-  id=`grep em:id beagle-extension/install.rdf | head -1 | sed -e 's/^ *//' -e
"s/<[^<]*>//g" | tr -d "\n\r"`
-  if [ -e "$id" ]; then
-    rm -rf beagle-extension
-  else
-    mv beagle-extension "$id"
-  fi
-
-  echo "$ffdir/extensions/$id" >  %{_libdir}/beagle/beagle-plugin-path
-fi
-
-%triggerun -- firefox
-# uninstall the firefox extension
-if [ $2 = 0 -a -f %{_libdir}/beagle/beagle-plugin-path ]; then
-  old=`cat %{_libdir}/beagle/beagle-plugin-path`
-  rm -rf $old
-  rm -rf  %{_libdir}/beagle/beagle-plugin-path
-fi
-
 %files -f %{name}.lang
 %defattr(-,root,root,-)
 %doc COPYING README
@@ -280,8 +227,8 @@ fi
 %{_libdir}/beagle/DocExtractor.exe*
 #Disabled for now (#205985)
 #%{_libdir}/beagle/Backends/ThunderbirdBackends.dll*
-# firefox plugin:
-%{_libdir}/beagle/beagle.xpi
+# firefox extension:
+%{_libdir}/xulrunner/extensions/%{firefox_app_id}/beagle.xpi
 %{_datadir}/beagle
 %{_mandir}/*/*
 %dir %attr(-,beaglidx,beaglidx) /var/cache/beagle
Comment 1 Christopher Aillon 2008-02-15 16:59:49 EST
*** Bug 431157 has been marked as a duplicate of this bug. ***
Comment 2 Adel Gadllah 2008-02-17 12:27:13 EST
*** Bug 432571 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Aillon 2008-02-18 01:56:29 EST
Oops, I meant $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{firefox_app_id}/  
(mozilla, not xulrunner)
Comment 4 Christopher Aillon 2008-02-18 18:34:53 EST
*** Bug 433376 has been marked as a duplicate of this bug. ***
Comment 5 Adel Gadllah 2008-02-23 07:37:33 EST
Should be fixed in beagle-0.3.3-6.fc9. (which will be in the next rawhide push)

Note You need to log in before you can comment on or make changes to this bug.