Bug 432649 - NetworkManager fails with segfault in nm-system-settings
NetworkManager fails with segfault in nm-system-settings
Status: CLOSED DUPLICATE of bug 434919
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 11:44 EST by Simon Karpen
Modified: 2008-03-02 20:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 20:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report from nm-applet (8.36 KB, text/plain)
2008-02-13 22:36 EST, Simon Karpen
no flags Details

  None (edit)
Description Simon Karpen 2008-02-13 11:44:01 EST
Description of problem: NetworkManager fails to work due to a segmentation fault
in nm-system-settings. From /var/log/messages, at networkmamager start:

Feb 13 11:13:37 localhost NetworkManager: <info>  Trying to start the system
settings daemon...
Feb 13 11:13:37 localhost kernel: nm-system-setti[11013]: segfault at 8 rip
2aaaab408655 rsp 7fff658de150 error 4
Feb 13 11:13:37 localhost NetworkManager: file dbus-gproxy.c: line 659
(unassociate_proxies): assertion failed: (priv->associated)
Feb 13 11:13:37 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught
signal 6.  Generating backtrace...
Feb 13 11:13:37 localhost kernel: nm-system-setti[11015]: segfault at 8 rip
2aaaab408655 rsp 7fff0efe9860 error 4
Feb 13 11:13:37 localhost NetworkManager: ******************* START
**********************************
Feb 13 11:13:37 localhost NetworkManager: Using host libthread_db library
"/lib64/libthread_db.so.1".
Feb 13 11:13:37 localhost NetworkManager: ******************* END
**********************************



Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.8.svn3302.fc9.x86_64


How reproducible: always


Steps to Reproduce:
1. boot system or run /etc/init.d/NetworkManager start
2. view errors in logs
3.
  
Actual results:
nm-system-settings fails with segmentation fault

Expected results:
working Networkmanager

Additional info:
iwl4965 and e1000 NICs, both controlled by NetworkManager (Thinkpad X61s)
Rawhide upgraded from F-8, not clean install of F-9-alpha
Comment 1 Simon Karpen 2008-02-13 22:36:49 EST
Created attachment 294877 [details]
Crash report from nm-applet

This is a crash report from nm-applet; this is what I get when I do
"/etc/init.d/NetworkManager start" while in GNOME.
Comment 2 Simon Karpen 2008-02-20 13:10:32 EST
With the latest (svn3319) NetworkManager packages, I'm instead getting the
following:

Feb 20 11:48:34 localhost kernel: nm-system-setti[2384]: segfault at 8 ip
7fecc62c4273 sp 7fffcf713260 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7fecc62bf000+9000]
Feb 20 11:48:34 localhost kernel: nm-system-setti[2388]: segfault at 8 ip
7f86b1d21273 sp 7fffbb1709f0 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f86b1d1c000+9000]
Feb 20 11:48:34 localhost kernel: nm-system-setti[2390]: segfault at 8 ip
7f5a562b0273 sp 7fff5f6fff80 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f5a562ab000+9000]
Feb 20 11:48:34 localhost kernel: nm-system-setti[2392]: segfault at 8 ip
7f5d611ad273 sp 7fff6a5fae80 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f5d611a8000+9000]
Feb 20 11:48:35 localhost kernel: nm-system-setti[2394]: segfault at 8 ip
7f40ddc33273 sp 7fffe7082900 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f40ddc2e000+9000]
Feb 20 11:48:35 localhost kernel: nm-system-setti[2396]: segfault at 8 ip
7f12af477273 sp 7fffb88c5140 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f12af472000+9000]
Feb 20 11:48:35 localhost kernel: nm-system-setti[2398]: segfault at 8 ip
7f2d07daa273 sp 7fff111f9a80 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f2d07da5000+9000]
Feb 20 11:48:35 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught
signal 6.  Generating backtrace...
Feb 20 11:48:35 localhost kernel: nm-system-setti[2400]: segfault at 8 ip
7f1160eeb273 sp 7fff6a338bc0 error 4 in
libnm-settings-plugin-ifcfg-fedora.so[7f1160ee6000+9000]
Feb 20 11:48:39 localhost NetworkManager: #1  0x00000000004246d3 in
nm_logging_backtrace ()
Feb 20 11:48:39 localhost NetworkManager: #1  0x00000000004246d3 in
nm_logging_backtrace ()
Feb 20 13:03:19 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught
signal 15, shutting down normally.

Please let me know if you need any other information. 
Comment 3 Dan Williams 2008-02-20 13:19:27 EST
Could you install NetworkManager-debuginfo:

sudo yum install --enablerepo=updates-debuginfo

then get the PID of nm-system-settings, and 'gdb attach <pid>', then type 'c' to
continue.  When the system settings process finally dies with a SIGSEGV, please
type 'bt' and paste that output into this bug report.

You can also use the same trick on NetworkManager itself to get a better
backtrace from NM, which would be useful.  Thanks!  If you need more explanation
let me known.
Comment 4 Dan Williams 2008-02-29 15:57:57 EST
Also, are you running SELinux enabled?  'getenforce' as 'root' will tell you.
Comment 5 Simon Karpen 2008-03-01 11:40:38 EST
I just installed the debuginfo packages and will get the backtrace.

I am NOT running with SELinux; getenforce returns Permissive and
/selinux/enforce contains a zero. 
Comment 6 Simon Karpen 2008-03-01 11:52:36 EST
Yum says the debuginfo isn't available:

[root@localhost init.d]# debuginfo-install NetworkManager

enabling development-debuginfo
Reading repository metadata in from local files
Could not find debuginfo for main pkg: 1:NetworkManager-0.7.0-0.8.svn3319.fc9.x86_64

It found plenty of debuginfo for supporting libraries though.

Next steps?
Comment 7 Dan Williams 2008-03-02 20:21:08 EST
Likely a dupe of #434919; should be fixed in svn3370

*** This bug has been marked as a duplicate of 434919 ***

Note You need to log in before you can comment on or make changes to this bug.