This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 434919 - NM in updates testing 0.7.0-0.6.7.svn3302 dies
NM in updates testing 0.7.0-0.6.7.svn3302 dies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 432649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-26 03:40 EST by Peter Robinson
Modified: 2008-04-22 18:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.7.svn3370.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:43:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NM Crash (9.42 KB, text/plain)
2008-02-26 03:40 EST, Peter Robinson
no flags Details
selinux for nm-system-settings (2.91 KB, text/plain)
2008-02-26 10:38 EST, Peter Robinson
no flags Details
Backtrace from svn3369 (4.25 KB, application/octet-stream)
2008-03-02 11:06 EST, James Begley
no flags Details

  None (edit)
Description Peter Robinson 2008-02-26 03:40:53 EST
I posted this message to the fedora-test list about the latest update of NM in
updates-testing 

https://www.redhat.com/archives/fedora-test-list/2008-February/msg00381.html

Versions running are:
NetworkManager-gnome-0.7.0-0.6.7.svn3302.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3302.fc8
NetworkManager-devel-0.7.0-0.6.7.svn3302.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8
NetworkManager-glib-devel-0.7.0-0.6.7.svn3302.fc8
NetworkManager-debuginfo-0.7.0-0.6.7.svn3302.fc8
NetworkManager-0.7.0-0.6.7.svn3302.fc8

I've tried reinstalling the rpms and done a rpm -Va to ensure no corruption but
I still have it all die. Unfortunately I've has to revert to 'ifup eth0' :-(

Not much has changed since the post to the mailing list

[root@euuklonw7300b1n ~]# service NetworkManager status
NetworkManager dead but pid file exists

I get alot of these messages through dmesg
[root@euuklonw7300b1n ~]# dmesg | grep nm-system
nm-system-setti[2559]: segfault at 8 rip 2aaaaaefa36a rsp 7fffad5d8670 error 4
nm-system-setti[2561]: segfault at 8 rip 2aaaaaefa36a rsp 7fffb7e156d0 error 4

And this time while going through the debug to retest I got the following
nm-applet crash.

I have the following network devices if that helps:
Intel Pro Wireless - iwl3945
Broadcom BCM4401-B0 - b44
Huawei E220 WWAN usb dongle on 3UK (not always plugged in, but never actually
got to work yet)

Let me know if you need more information.
Comment 1 Peter Robinson 2008-02-26 03:40:53 EST
Created attachment 295883 [details]
NM Crash
Comment 2 Dan Williams 2008-02-26 10:22:55 EST
Do you have SELinux turned on, in enforcing or permissive mode, and what version
of the selinux-policy-targeted RPM do you have installed?
Comment 3 Peter Robinson 2008-02-26 10:37:15 EST
policy rpm version is
selinux-policy-targeted-3.0.8-87.fc8

Its in permissive mode. Will attach the output from a settroubleshoot browser
thingy.

Comment 4 Peter Robinson 2008-02-26 10:38:18 EST
Created attachment 295937 [details]
selinux for nm-system-settings
Comment 5 Peter Robinson 2008-02-29 05:34:05 EST
I've has to roll back to NM 0.7.0-0.6.7.svn3235.fc8 as I'm travelling next week
and can't live without ease of use wireless :-)

I did a 'rpm -e --nodeps' to force removal of NM and a 'yum install' with the
updates-testing repo disabled and then just did a 'service NetworkManager
restart' and appart from a error saying that NM can't find all the resources (or
something like that) which I suspect is due to the downgrade its running fine
which indicates its more that version for me than my system.

Is there anything further I can test to help in the debug of this?

Peter
Comment 6 James Begley 2008-03-02 09:42:49 EST
svn3369.fc8 has the same problems for me.  The nm-applet dies, and syslog gets 
flooded with messages like

Mar  2 14:20:45 jumbovaio kernel: nm-system-setti[2399]: segfault at 00000004 
eip 0017fbdb esp bf9a38a0 error 4
Mar  2 14:20:45 jumbovaio NetworkManager: <info>  Trying to start the system 
settings daemon...
Mar  2 14:20:45 jumbovaio kernel: nm-system-setti[2449]: segfault at 00000004 
eip 0017fbdb esp bfc40640 error 4
Mar  2 14:20:45 jumbovaio NetworkManager: <info>  Trying to start the system 
settings daemon...
Mar  2 14:20:45 jumbovaio kernel: nm-system-setti[2451]: segfault at 00000004 
eip 0017fbdb esp bfa5ac60 error 4
Mar  2 14:20:45 jumbovaio NetworkManager: <info>  Trying to start the system 
settings daemon...
Mar  2 14:20:45 jumbovaio kernel: nm-system-setti[2453]: segfault at 00000004 
eip 0017fbdb esp bf967b70 error 4


Other information:
selinux is in permissive mode
wireless card is using the iwl3945 driver
no 3g card installed.

Rolling back to svn3235 gets the wireless card to work again.
Comment 7 Dan Williams 2008-03-02 10:01:21 EST
Can you do the following for me please:

1) Download the appropriate debuginfo for your machine:
http://koji.fedoraproject.org/packages/NetworkManager/0.7.0/0.6.7.svn3369.fc8/i386/NetworkManager-debuginfo-0.7.0-0.6.7.svn3369.fc8.i386.rpm
http://koji.fedoraproject.org/packages/NetworkManager/0.7.0/0.6.7.svn3369.fc8/x86_64/NetworkManager-debuginfo-0.7.0-0.6.7.svn3369.fc8.x86_64.rpm

2) yum install gdb glib2-debuginfo libnl-debuginfo

3) /sbin/service NetworkManager stop

4) gdb /usr/sbin/nm-system-settings

5) r --plugins=ifcfg-fedora

6) when it crashes, type 'backtrace', copy and paste the output of the backtrace
into this bug

Thanks!
Comment 8 James Begley 2008-03-02 11:06:20 EST
Created attachment 296515 [details]
Backtrace from svn3369

Backtrace as requested.

Note that I have libnl-1.1-1.fc8 from updates testing, if this makes any
difference.  Still works OK with svn 3235 though.
Comment 9 Dan Williams 2008-03-02 20:04:34 EST
Thanks!  I think I've found it.  Can you verify that the file
'/etc/sysconfig/networking/profiles/default/ifcfg-wlan0' on your system is
missing the ESSID= line?  Without an SSID, there's not much NM can do with the
file, but the system settings service wasn't correctly handling the missing
ESSID= tag case.
Comment 10 Dan Williams 2008-03-02 20:21:09 EST
*** Bug 432649 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2008-03-02 20:58:56 EST
NetworkManager-0.7.0-0.6.7.svn3370.fc8 has been submitted as an update for Fedora 8
Comment 12 James Begley 2008-03-03 13:12:33 EST
The file /etc/sysconfig/networking/profiles/default/ifcfg-wlan0 has a blank 
ESSID line:

# Intel Corporation PRO/Wireless 3945ABG Network Connection
DEVICE=wlan0
BOOTPROTO=dhcp
HWADDR=XX:XX:XX:XX:XX:XX  # details blanked out
ONBOOT=yes
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
TYPE=Wireless
ESSID=
CHANNEL=
MODE=
RATE=

Also, I'm pleased to confirm that the svn3370.fc8 builds now work correctly for 
me.

Thanks.
Comment 13 Fedora Update System 2008-03-03 13:25:04 EST
NetworkManager-0.7.0-0.6.7.svn3370.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2225
Comment 14 Peter Robinson 2008-03-06 17:04:21 EST
This is fixed for me in:
NetworkManager-0.7.0-0.6.7.svn3370.fc8
kernel-2.6.24.3-12.fc8

Cheers
Comment 15 Fedora Update System 2008-04-22 18:43:35 EDT
NetworkManager-0.7.0-0.6.7.svn3370.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.