Bug 432653 - RHEL4.8: Modify SATA IDE mode quirk
RHEL4.8: Modify SATA IDE mode quirk
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
high Severity medium
: rc
: ---
Assigned To: Bhavna Sarathy
Martin Jenner
: OtherQA
Depends On:
Blocks: AMD4.8 458123 461297
  Show dependency treegraph
 
Reported: 2008-02-13 11:54 EST by Bhavna Sarathy
Modified: 2010-10-22 18:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 14:29:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhavna Sarathy 2008-02-13 11:54:24 EST
+++ This bug was initially created as a clone of Bug #432652 +++

AMD chipset dev, team has been moving towards unifying SB600/700/800 support.
This patch was approved by Jeff Garzik and is necessary to initialize ans set
SATA mode correctly.

http://marc.info/?l=linux-pci&m=120193321032703&w=2
Comment 1 Shane Huang 2008-03-17 04:10:06 EDT
upstream commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=05a7d22b9f02e7fe8fb5ff972b46743948139b3c
Comment 2 Bhavna Sarathy 2008-03-19 12:02:07 EDT
Russ, please add to R4.7 tracker.  This is the RHEL4 bug for the IDE mode quirk
we're working on for RHEL5.
Comment 3 RHEL Product and Program Management 2008-03-19 15:20:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Shane Huang 2008-03-26 23:29:51 EDT
Please just pause to add patch to RHEL4.7 until we test the kernel rpm package 
from Bhavana.

Thanks
Comment 5 Bhavna Sarathy 2008-04-08 16:06:25 EDT
Shane, it may be worthwhile to sum up your findings regarding CONFIG_APIC no
support S3/S4 events in the GNOME.   Please also mention systems details as
well.  Are there addditional work that is needed in RHEL4.7?  

Peter, this is hampering AMD chipset team's testing efforts, at this point they
are unable to test the IDE patch.   Please include the apropriate folks who can
perhaps talk to the current status of S3/S4 in RHEL4.7?

Many thanks,
Bhavana

Comment 6 Peter Martuccelli 2008-04-08 16:27:03 EDT
Bhavana we are past code freeze for RHEL 4.7.  Russ will have to get this issue
approved as an excpeion to be considered for inclusion post code freeze.  I am
reverting the devel ack until I hear the pending issues from Shane.  After I
read the update I will determine who is availableto help out on the issue(s). 
Comment 7 Shane Huang 2008-04-08 23:12:11 EDT
We also tried one Intel platform(ICH7) with RHEL4.6 GA WS i386,
finding that ACPI can NOT work either.

So I think this patch can be delayed until RedHat support ACPI in RHEL4.

Thanks
Comment 8 Bhavna Sarathy 2008-04-18 16:28:20 EDT
Shane, please sum up your ACPI findings and list what is missing in R4 code base
as I requested in comment#5.  Based on that the Red HAt engineering manager will
figure out who at Red Hat can help with this work.

Bhavana
Comment 9 Peter Martuccelli 2008-04-22 16:02:57 EDT
We are past code freeze, moving this issue out to 4.8.
Comment 10 henry su 2008-04-22 22:03:11 EDT
The following items are what I found in RHEL4.6 on RS690/SB600:
1. The system cannot suspend to ram with "echo mem > /sys/power/state", it 
return back to console, no additional output in dmesg.
2. No suspend routines of the chipset drivers are called to suspend the devices 
while suspending the system.
Comment 11 RHEL Product and Program Management 2008-09-03 08:57:38 EDT
Updating PM score.
Comment 12 Joachim Deguara 2009-01-16 13:26:07 EST
patch now posted to rhkernel-list
Comment 13 Linda Wang 2009-01-16 14:31:33 EST
has the patch been tested?  Please provide test results.
Comment 14 Shane Huang 2009-01-19 22:24:08 EST
Linda, actually, the patch is necessary at ACPI S3 resume.
Since we find that ACPI can NOT work in RHEL4.x, we are NOT able to test it.

Can you check with ACPI maintainer in RedHat for the status of RHEL4.x ACPI support?
If RH can confirm that RHEL4.x do NOT support ACPI, we need not add this patch.

Thanks,
Comment 15 Prarit Bhargava 2009-02-11 09:04:14 EST
(In reply to comment #14)
> Linda, actually, the patch is necessary at ACPI S3 resume.
> Since we find that ACPI can NOT work in RHEL4.x, we are NOT able to test it.
> 

ACPI is enabled on ia64, x86, and x86_64 in RHEL4.

[prarit@prarit configs]$ egrep 'CONFIG_ACPI=y' *
config-ia64-generic:115:CONFIG_ACPI=y
config-x86_64-generic:59:CONFIG_ACPI=y
config-x86-generic:126:CONFIG_ACPI=y

Shane, could you provide more details as to what you think is broken (or missing) in RHEL4?

Thanks,

P.
Comment 16 Arindam Nath 2009-02-17 05:25:17 EST
The S3/S4 code base in RHEL4.7 kernel-2.6.9-78.ELsmp doesn't support SMP platform. The following git patches need to be backported to make it work for both i386 and x86_64.

1. http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=5a72e04df5470df0ec646029d31e5528167ab1a7

2. http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=f370513640492641b4046bfd9a6e4714f6ae530d

3. http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=76e4f660d9f4c6d1bb473f72be2988c35eaca948

Thanks,
Arindam
Comment 18 Peter Martuccelli 2009-02-18 14:44:30 EST
The patch set is too large for consideration to be included in RHEL4.  We can release note that we do not support suspend to ram for the SB(6,7,8)00 chipsets.  Any additional runtime issues that need to be addressed?  If not then we should close out this request as wont fix
Comment 19 Shane Huang 2009-02-19 00:44:42 EST
Peter,

I don't think the issue is specific to AMD SB600/SB700/SB800.
What is the S3 status on other platforms? like the one from Intel or nVidia?

If S3 can work on these platforms, can you tell me the command to enter S3?
Is it "echo mem > /sys/power/state"?

BTW,
S3 can NOT work either on my SB700 platform with UP plus 2.6.9-78.EL kernel,
by "echo mem > /sys/power/state"

Thanks
Comment 20 Peter Martuccelli 2009-02-25 14:26:51 EST
We will not be considering the patch set listed in comment #16, it is too invasive a change for RHEL4.  Any SMP system running RHEL4 will fail trying to suspend, reference the patch set listed in comment #16.  The "echo mem > /sys/power/state" is the proper command to suspend to ram.  If UP is not working on the SB700 platforms then you are free to work with Bhavna to resolve the issue.  Please be aware that we are past code freeze for RHEL4.8 so we will not be taking in any subsequent patches to resolve the UP problem at this time.

Devel NAK for RHEL4.
Comment 21 RHEL Product and Program Management 2009-02-25 14:29:20 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 22 Shane Huang 2009-02-25 20:41:19 EST
One question here: which statement will be added to your RHEL4.x release note?
You will not specify AMD platforms for S3 failure, right?

Note You need to log in before you can comment on or make changes to this bug.