Bug 432934 - error while loading shared libraries: libgij.so.7rh: cannot open shared object file: No such file or directory, RHEL4U6->RHEL5.2 upgrade
error while loading shared libraries: libgij.so.7rh: cannot open shared objec...
Status: CLOSED DUPLICATE of bug 432773
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.4.2-gcj-compat (Show other bugs)
5.2
All Linux
low Severity low
: beta
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 05:08 EST by Alexander Todorov
Modified: 2008-02-19 16:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 16:21:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-02-15 05:08:08 EST
Description of problem:
Multiple error messages during RHEL4U6->RHEL5.2 upgrade, related to gcj package
and friends.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp.112
eclipse-ecj-3.2.1-19.el5
antlr-2.7.6-4jpp.2
gjdoc-0.7.7-12.el5
postgresql-jdbc-8.1.407-1jpp.4

RHEL5.2-Server-20080212.0

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4-U6-AS, @everything
2. Upgrade to RHEL 5.2 using anaconda
3.
  
Actual results:
multiple errors in install log

Expected results:
no errors

Additional info:
Could it be related to bug #432931?
Does the errors below show other issues that need to be filed separately?

Error(s) installing: java-1.4.2-gcj-compat 1.4.2.0 40jpp.112 ia64
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory
Error(s) installing: eclipse-ecj 1:3.2.1 19.el5 ia64
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
Error(s) installing: antlr 2.7.6 4jpp.2 ia64
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
Error(s) installing: gjdoc 0.7.7 12.el5 ia64
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
Error(s) installing: postgresql-jdbc 8.1.407 1jpp.4 ia64
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.
mkdir: missing operand
Try `mkdir --help' for more information.
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory
Comment 2 RHEL Product and Program Management 2008-02-15 05:27:41 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Thomas Fitzsimmons 2008-02-19 11:17:08 EST
Can you post install.log from the affected system?
Comment 8 Thomas Fitzsimmons 2008-02-19 13:24:17 EST
This error may be to blame:

Upgrading libgcj - 4.1.2-39.el5.ia64
error: unpacking of archive failed on file /usr/lib/gcj-4.1.2: cpio: rename

/usr/bin/gij, /usr/bin/gcj-dbtool and /usr/lib/libgij.so.7rh all belong to the
libgcj package.  If cpio installs /usr/bin/gij and /usr/bin/gcj-dbtool then
exits-on-error before installing /usr/lib/libgcj.so.7rh, that would explain
subsequent error messages like:

gij: error while loading shared libraries: libgij.so.7rh: cannot open shared
object file: No such file or directory

and

/usr/bin/gcj-dbtool: error while loading shared libraries: libgcj.so.7rh: cannot
open shared object file: No such file or directory

when %post sections of later-installed packages invoke these commands.
Comment 9 Thomas Fitzsimmons 2008-02-19 16:21:04 EST

*** This bug has been marked as a duplicate of 432773 ***

Note You need to log in before you can comment on or make changes to this bug.