Bug 432958 - Kernel 2.6.25-0.40.rc1.git2.fc9 hangs on boot
Kernel 2.6.25-0.40.rc1.git2.fc9 hangs on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 433438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 08:13 EST by Bob Agel
Modified: 2008-09-14 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.25-0.54.rc2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 20:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (22.44 KB, application/octet-stream)
2008-02-16 07:47 EST, Bob Agel
no flags Details

  None (edit)
Description Bob Agel 2008-02-15 08:13:27 EST
Description of problem:
new kernel hangs on boot after detecting usb2-1 (printer)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.

Actual results: new kernel fails to boot, 2.6.25-0.35.rc1.fc9 is fine.


Expected results:


Additional info:
Comment 1 Konstantin 2008-02-15 17:15:10 EST
Same for me, file system doesn't mount, boot hangs after USB devices detection.
Comment 2 Bob Agel 2008-02-15 22:47:16 EST
Based on dmesg from the working kernel, git2 is hanging at these lines:

Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x2304
usbcore: registered new interface driver usblp
Comment 3 Pete Zaitcev 2008-02-15 23:36:04 EST
What would the working kernel do next?  It's unthinkable to imagine
usblp giving such kind of trouble, so it must be something that comes
after it.
Comment 4 Bob Agel 2008-02-16 07:47:57 EST
Created attachment 295067 [details]
dmesg
Comment 5 Bob Agel 2008-02-16 07:48:50 EST
Comment on attachment 295067 [details]
dmesg

Here's the whole dmesg; still hangs exactly at the same point.
Comment 6 Rene Rask 2008-02-16 15:26:47 EST
First boot after upgrading to 2.6.25-0.40.rc2.git2.fc9 detected my wacom tablet,
then my usb-modem(huawei e220) stops.
Second attempt detected the modem first but not the tablet.
Plugging/unplugging devices fires events which get printed.
I also have a usb-mouse plugged which didn't show at all.
This is on a Toshiba Qosmio G30.
Comment 7 Rene Rask 2008-02-18 22:53:14 EST
I took a look at the initrd file and compared it to the previous working kernel.
I first created a new initrd using:
 mkinitrd /boot/initrd-.6.25-0.40.rc1.git2.fc9-2.img 2.6.25-0.40.rc1.git2.fc9
which also failed to boot. Then manually specified these modules:
mkinitrd --with scsi_mod --with sd_mod --with libata --with ahci -f
/boot/initrd-2.6.25-0.40.rc1.git2.fc9-2.img  2.6.25-0.40.rc1.git2.fc9
Which boots the system with no problems.
I guess the kernel needs libata to see any disks so it can continue the boot
sequence, but why doesn't it die with the using AII! PANIC message about not
being able to find the root filesystem is just weird.

The usb messages didn't show up when I unplugged all of them for testing.
Booting stopped just where the PANIC messages usually shows up with some of the
usual suspects being present but not the PANIC itself.
A userfriendly way to send dmesg output over the wire would be nice ;)
Comment 8 Bob Agel 2008-02-21 14:34:24 EST
Today's update to 2.6.25-0.54.rc2.fc9 fixes the problem - booting normally now.
Comment 9 Charles R. Anderson 2008-02-22 11:27:22 EST
*** Bug 433438 has been marked as a duplicate of this bug. ***
Comment 10 Tim Waugh 2008-02-22 11:32:57 EST
2.6.25-0.54.rc2.fc9 working fine here too.
Comment 11 Bug Zapper 2008-05-14 01:13:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.