Bug 433125 - Kernel Oopses; Gnome applets crash on start
Kernel Oopses; Gnome applets crash on start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 11:30 EST by Horst H. von Brand
Modified: 2008-03-15 11:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-15 11:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (11.05 KB, text/plain)
2008-02-16 11:30 EST, Horst H. von Brand
no flags Details
Xorg.0.log when X crashes on x86_64 (55.76 KB, text/plain)
2008-02-18 09:06 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-02-16 11:30:55 EST
Description of problem:
I got several oopses with the kernel, and several Gnome applets (Fish, CPU
Frequency Scaling (this is a dual-core i686), perhaps others) crash on start.
Only the Show Desktop Button showed up (I've got Show Desktop Button, Fish,
Clock, CPU Frequency Scaling Monitor, setroubleshoot, Power Manager, Network
Manager Applet).

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.40.rc1.git2.fc9.i686

How reproducible:
Booted once with dire results, didn't try again. With
kernel-2.6.24.1-28.fc9.i686 the same applets work fine.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Got reported by kerneloops too.
Comment 1 Horst H. von Brand 2008-02-16 11:30:55 EST
Created attachment 295076 [details]
dmesg output
Comment 2 Horst H. von Brand 2008-02-16 11:35:58 EST
From the About for each applet:
- Show Desktop Button 2.21.91
- Fish 3.4.7.4ac19
- Clock 2.21.91
- CPU Frequency Scaling Monitor 2.21.91
- Power Manager 2.21.92
- NetworkManager Applet 0.7.0

setroubleshoot-2.0.5-1.fc9.noarch (no "About..." for this one)
Comment 3 Horst H. von Brand 2008-02-18 09:06:52 EST
Created attachment 295167 [details]
Xorg.0.log when X crashes on x86_64

On x86_64 with the same kernel, X doesn't start ("X respawning too fast", etc).

Who on Earth is 200.160.240.20, why are they trying to connect here?! The IP
belongs to a machine in Brazil.
Comment 4 Eric Paris 2008-02-18 14:54:24 EST
I'm certainly not sure because i just saw BZ 433339 just a second ago, but all
of the WARNING() stuff in dmesg looks to be a seperate and unrelated issue. 
They shouldn't be harming anything other than system performance and wasting log
space.  If you don't mind, would you please post your auditctl -l output into BZ
433339 and attempt to verify that the appearance of these WARN messages in dmesg
do not coincide with a failure?
Comment 5 Eric Paris 2008-02-18 18:12:23 EST
I take that back, it is possible that BZ 433339 is sending SIGKILL to your
apps...  So this one might want to wait a bit till I can get that one fixed to
see if they are the same problem  (as an alternative, remove all audit rules and
see if that fixes this bug, if so, this is a dup)
Comment 6 Horst H. von Brand 2008-02-25 07:20:52 EST
How do I remove audit rules? I haven't touched anything there AFAIR.
Comment 7 Horst H. von Brand 2008-02-25 07:23:32 EST
O, BTW, with the last Gnome (gnome-settings-daemon-2.21.91-3.fc9.i386) I see
lots of other problems. See https://bugzilla.redhat.com/show_bug.cgi?id=434772
for details. And this is with the last working kernel-2.6.24.1-28.fc9.i686
Comment 8 Horst H. von Brand 2008-03-15 11:09:25 EDT
Now it works, and has for a while.

Note You need to log in before you can comment on or make changes to this bug.