Bug 434772 - Crash on start
Crash on start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liboil (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 434922 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 07:11 EST by Horst H. von Brand
Modified: 2008-02-26 06:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.3.13-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 18:26:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Startup message (copy-pasted text) (302 bytes, text/plain)
2008-02-25 07:11 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2008-02-25 07:11:16 EST
Description of problem:
Starting Gnome (from XDM, GDM currently crashes X) I get a message that the
settings daemon doesn't start, and much of Gnome is non-functional.

Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.21.91-3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Start Gnome
2.
3.
  
Actual results:
See attached file (error message). Most applets don't start. Keyboard is set to
Spanish (system wide setting), but I have to run system-config-keyboard again to
get a half-working keyboard (AltGr is a new Enter, Alt is completely
non-functional, no arrow keys). Shutting down from the System menu doesn't do
anything.

Expected results:


Additional info:
Comment 1 Horst H. von Brand 2008-02-25 07:11:16 EST
Created attachment 295790 [details]
Startup message (copy-pasted text)
Comment 2 Bastien Nocera 2008-02-25 08:51:10 EST
That would be because GDM has a window manager and a gnome-settings-daemon, and
doesn't shut them down/clear the environment before starting the session.

It might also be because you're using liboil 0.3.13.
Comment 3 Rob Riggs 2008-02-25 17:37:52 EST
Similar problem, only occurred after this morning's yum update and reboot.  This
occurs on an x86_64 system.  No error messages on screen, it just returns me to
the gdm login.

.xsession-errors contains the following:

The program 'gnome-session' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 21 error_code 3 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I am using liboil-0.3.13: liboil-0.3.13-1.fc9.x86_64

liboil was updated this morning.  GDM was not. And neither was gnome-session.

gdm-2.21.7-1.fc9.x86_64
gnome-session-2.21.91-1.fc9.x86_64

What's the issue with liboil-0.3.13?  I don't see a bug report.

Comment 4 Bastien Nocera 2008-02-25 18:26:00 EST
Matthias fixed the crasher this morning, fix will be in liboil-0.3.13-2.fc9:
http://koji.fedoraproject.org/koji/buildinfo?buildID=39842
Comment 5 Bastien Nocera 2008-02-26 06:10:20 EST
*** Bug 434922 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.