This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 433157 - [lockdep] Hang on boot: INFO: possible recursive locking detected & BUG: soft lockup - CPU#1 stuck for 61s! [wpa_supplicant:2490]
[lockdep] Hang on boot: INFO: possible recursive locking detected & BUG: soft...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 433329 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2008-02-16 19:47 EST by Tom London
Modified: 2008-12-26 12:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-26 12:31:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages when NetworkManager starts, system hangs (15.27 KB, text/plain)
2008-02-16 19:47 EST, Tom London
no flags Details
more lockdep messages from /var/log/messages (10.57 KB, text/plain)
2008-02-17 20:26 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2008-02-16 19:47:42 EST
Description of problem:
kernel-2.6.25-0.50.rc2.fc9.i686 fails to complete init into runlevel 5

Get the INFO/recursive locking message when NetworkManager starts, and the
system "hangs": displays text login, but does not seem to accept any input.

I get the BUG/lockup after entering CTL-ALT-delete (the system does shutdown
"normally").

Sorry for jumping the gun on this version.... hoping to get one that supports
KVM ... :-)

System is a Thinkpad X60.

I'll attach what appears to be the relevant portion of /var/log/messages

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.50.rc2.fc9.i686

How reproducible:
Every time.

Steps to Reproduce:
1.  Install, boot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-02-16 19:47:42 EST
Created attachment 295083 [details]
/var/log/messages when NetworkManager starts, system hangs
Comment 2 Tom London 2008-02-17 17:29:21 EST
Issue seems to be with NetworkManager (and derived kernel support).

Booting in runlevel 3 with NetworkManager "turned off" works. I can bring up the
network interface manually and do a "startx" without problems.

[Booting in runlevel 3 with NM "turned on" produces above problems and freeze.
Comment 3 Tom London 2008-02-17 20:26:25 EST
Created attachment 295122 [details]
more lockdep messages from /var/log/messages

Got more:

Feb 17 17:22:15 localhost kernel: [ INFO: possible circular locking dependency
detected ]
Feb 17 17:22:15 localhost kernel: 2.6.25-0.50.rc2.fc9 #1
Feb 17 17:22:15 localhost kernel:
-------------------------------------------------------
Feb 17 17:22:15 localhost kernel: losetup/3515 is trying to acquire lock:
Feb 17 17:22:15 localhost kernel:  (&bdev->bd_mutex){--..}, at: [<c04aa5e2>]
__blkdev_put+0x24/0x12f
Feb 17 17:22:15 localhost kernel: 
Feb 17 17:22:15 localhost kernel: but task is already holding lock:
Feb 17 17:22:15 localhost kernel:  (&lo->lo_ctl_mutex){--..}, at: [<f8ef1087>]
lo_ioctl+0x3d/0xa01 [loop]
Feb 17 17:22:15 localhost kernel: 
Feb 17 17:22:15 localhost kernel: which lock already depends on the new lock.

Complete spew in the attachment.
Comment 4 Jeffrey Moyer 2008-02-18 10:37:34 EST
Looks like this was reported upstream:

  http://lkml.org/lkml/2008/2/15/542

The second lockup (comment #3) is a different issue and probably warrants a
separate bugzilla.
Comment 5 Tom London 2008-02-21 10:52:35 EST
Don't seem to be getting lockdep issue with kernel-2.6.25-0.61.rc2.git4.fc9.i686
Comment 6 Charles R. Anderson 2008-02-22 11:24:46 EST
*** Bug 433329 has been marked as a duplicate of this bug. ***
Comment 7 Bug Zapper 2008-05-14 01:14:29 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Tom London 2008-12-26 12:31:41 EST
Closing this.

Must be long gone by now.....

Note You need to log in before you can comment on or make changes to this bug.