Bug 433329 - lockdep: [ INFO: possible circular locking dependency detected ]
lockdep: [ INFO: possible circular locking dependency detected ]
Status: CLOSED DUPLICATE of bug 433157
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 12:52 EST by Tom London
Modified: 2008-02-22 11:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 11:24:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lockdep message on "losetup" (10.57 KB, text/plain)
2008-02-18 12:52 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2008-02-18 12:52:21 EST
Description of problem:
Get this when running "losetup" on usb hard drive:

Feb 17 17:22:15 localhost kernel: [ INFO: possible circular locking dependency
detected ]
Feb 17 17:22:15 localhost kernel: 2.6.25-0.50.rc2.fc9 #1
Feb 17 17:22:15 localhost kernel:
-------------------------------------------------------
Feb 17 17:22:15 localhost kernel: losetup/3515 is trying to acquire lock:
Feb 17 17:22:15 localhost kernel:  (&bdev->bd_mutex){--..}, at: [<c04aa5e2>]
__blkdev_put+0x24/0x12f
Feb 17 17:22:15 localhost kernel: 
Feb 17 17:22:15 localhost kernel: but task is already holding lock:
Feb 17 17:22:15 localhost kernel:  (&lo->lo_ctl_mutex){--..}, at: [<f8ef1087>]
lo_ioctl+0x3d/0xa01 [loop]
Feb 17 17:22:15 localhost kernel: 
Feb 17 17:22:15 localhost kernel: which lock already depends on the new lock.

Complete spew in the attachment.

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.50.rc2.fc9.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-02-18 12:52:21 EST
Created attachment 295184 [details]
lockdep message on "losetup"
Comment 2 Charles R. Anderson 2008-02-22 11:24:45 EST

*** This bug has been marked as a duplicate of 433157 ***

Note You need to log in before you can comment on or make changes to this bug.