Bug 433195 - gimp-libs should be dependency of gimp
gimp-libs should be dependency of gimp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 433334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 07:49 EST by vikram goyal
Modified: 2008-03-28 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 09:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vikram goyal 2008-02-17 07:49:17 EST
Description of problem:
One can update gimp without updating gimp-libs which makes gimp complain of libs
version diff from gimp binary

Version-Release number of selected component (if applicable):
gimp-2.4.4-1.fc8
gimp-libs-2.4.3-1.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nils Philippsen 2008-02-18 05:51:24 EST
Been updating manually with RPM, eh ;-)? Yum should have pulled the matching
gimp-libs package as well anyway. I'll check in changes which should make gimp,
gimp-devel require the correct version and architecture of gimp-libs (but won't
build new packages for F-7, F-8 right now as this can be easily worked around).
Comment 2 vikram goyal 2008-02-18 08:38:13 EST
Of course not, What rally happend was that yum check stated more than 200mb
downloads to update the whole set, so I saved the list and did the packs one by
one skipping the largers for night time.
Because of that, gimp came first from the list than the libs package. While
updating gimp it did not pull in libs and when I started gimp after that it borked.
Its just by chance that i discovered it so thought of reporting it
Comment 3 Nils Philippsen 2008-02-18 09:04:03 EST
Well, good catch then! Once the build system gets un-borked I'll build this for
Rawhide though, to see whether the dependencies work out as intended.
Comment 4 Nils Philippsen 2008-02-19 03:30:57 EST
*** Bug 433334 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-03-03 05:38:20 EST
gimp-2.4.5-1.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-03-03 07:31:03 EST
gimp-2.4.5-1.fc7 has been submitted as an update for Fedora 7
Comment 7 Fedora Update System 2008-03-03 13:22:25 EST
gimp-2.4.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gimp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2177
Comment 8 Fedora Update System 2008-03-28 09:57:38 EDT
gimp-2.4.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-03-28 09:58:53 EDT
gimp-2.4.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.