Bug 43323 - rpm-spec-mode in emacs-20.7-36 messes up C-u (universal-argument)!
Summary: rpm-spec-mode in emacs-20.7-36 messes up C-u (universal-argument)!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 44206 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-03 06:27 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-04 13:34:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-06-03 06:27:52 UTC
This line in rpm-spec-mode.el:

  (define-key rpm-spec-mode-map "\C-u\C-c\C-i" 'rpm-change-tag)

Makes C-u stop working properly as a universal argument when editing spec
files.  This is now what you need to do here.  What you need to do here is
something like this:

--- rpm-spec-mode.el	2001/06/03 06:30:17	1.1
+++ rpm-spec-mode.el	2001/06/03 06:29:47
@@ -325,7 +325,6 @@
   (define-key rpm-spec-mode-map "\C-cxt" 'rpm-toggle-test)
   ;;May be better to have movement commands on \C-ck, and build on
\C-c\C-k
   (define-key rpm-spec-mode-map "\C-c\C-i" 'rpm-insert-tag)
-  (define-key rpm-spec-mode-map "\C-u\C-c\C-i" 'rpm-change-tag)
   (define-key rpm-spec-mode-map "\C-c\C-n" 'rpm-forward-section)
   (define-key rpm-spec-mode-map "\C-c\C-p" 'rpm-backward-section)
   (define-key rpm-spec-mode-map "\C-c\C-t" 'rpm-insert-true-prefix)
@@ -659,9 +658,11 @@
       (message "Group tag not found..."))))
 
 (defun rpm-insert-tag (&optional arg)
-  "Insert a tag."
+  "Insert or change a tag."
   (interactive "p")
-  (rpm-insert))
+  (if current-prefix-arg
+      (rpm-change)
+    (rpm-insert)))
 
 (defun rpm-change-tag (&optional arg)
   "Change a tag."

Comment 1 Trond Eivind Glomsrxd 2001-06-04 13:34:41 UTC
I've sent a message about to the author to ask his opinon.

Comment 2 Trond Eivind Glomsrxd 2001-06-04 21:35:28 UTC
New rpm-spec-mode.el included in xemacs-21.1.14-11
 and emacs-20.7-37

Comment 3 Trond Eivind Glomsrxd 2001-06-12 14:19:28 UTC
*** Bug 44206 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.