Bug 433242 - backticks are converted to left quotes (can't search for ` in man page)
backticks are converted to left quotes (can't search for ` in man page)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 18:50 EST by Mikel Ward
Modified: 2008-02-17 19:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 19:18:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-02-17 18:50:36 EST
If a ` (0x60 = ASCII grave accent) appears in a man page (e.g.
/usr/share/man/man1/perlop.1.gz), it is converted into a ‘(0xE2 0x80 0x98 =
U+2018 = Unicode left single quotation mark).

This means I can't search for backticks in man pages.

Is there any way to fix this?  (The obvious alternative is U+0060 = grave
accent, but apparently this is a spacing character, and I'm not sure what effect
that would have.)
Comment 1 Mikel Ward 2008-02-17 18:52:51 EST
spacing sounds like exactly what I want
http://en.wikipedia.org/wiki/Non-spacing_character
(non-spacing means it doesn't advance the cursor)
Comment 2 Mikel Ward 2008-02-17 19:06:55 EST
According to groff_char(7), it should \[ga] (= grave accent), but I've also read
\' is the way to get one.

Will do some more digging.  Sounds like this will end up being a bug against
perldoc.
Comment 3 Mikel Ward 2008-02-17 19:18:34 EST
Not a bug.  See bug 433243.

Note You need to log in before you can comment on or make changes to this bug.