Bug 433254 - Rebuild for trident driver for rawhide
Rebuild for trident driver for rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-trident (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 433423
  Show dependency treegraph
 
Reported: 2008-02-18 01:35 EST by Alex Lancaster
Modified: 2009-10-22 08:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 02:53:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (26.49 KB, text/plain)
2008-02-18 23:58 EST, Alex Lancaster
no flags Details
new /var/log/Xorg.0.log (29.98 KB, text/plain)
2008-02-19 01:45 EST, Alex Lancaster
no flags Details

  None (edit)
Description Alex Lancaster 2008-02-18 01:35:46 EST
My X server won't start because the trident driver hasn't been rebuilt for the
new xorg release:

Upon running "startx", message is something like (copied manually):

(EE) module ABI major verion (1) doesn't match the server's version (4)
(EE) Failed to load module "trident" (module requirement mismatch, 0)
(EE) no drivers available
Comment 1 Adam Jackson 2008-02-18 10:45:51 EST
Yeah, that'll happen.  It's not been pciaccess'd yet.
Comment 2 Dave Airlie 2008-02-18 15:42:34 EST
can you test the packages here?

http://koji.fedoraproject.org/scratch/airlied/task_436551/

Comment 3 Alex Lancaster 2008-02-18 23:58:03 EST
Created attachment 295258 [details]
/var/log/Xorg.0.log

Installed the new driver, and the xorg server now recognises the new driver,
but something prevents it from launching, get the following:

(EE) TRIDENT(0): Unable to map IO aperture. Invalid argument (22)
Fatal server error:
AddScreen/ScreenInit failed for driver 0

and X won't start.  I can get it to start by removing the driver completely,
and now X falls back to using the vesa driver.
Comment 4 Dave Airlie 2008-02-19 00:30:44 EST
can you send me an lspci -vvv as root from that box?

I think the sizing code is wrong....

Comment 5 Alex Lancaster 2008-02-19 00:39:58 EST
Is this sufficient (I just cut out the Trident-specific output)?


00:14.0 VGA compatible controller: Trident Microsystems Cyber 9525 (rev 49)
(prog-if 00 [VGA controller])
        Subsystem: Fujitsu Limited. Unknown device 1094
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at fe800000 (32-bit, non-prefetchable) [size=4M]
        Region 1: Memory at fe120000 (32-bit, non-prefetchable) [size=128K]
        Region 2: Memory at fe400000 (32-bit, non-prefetchable) [size=4M]
        Capabilities: [80] AGP version 1.0
                Status: RQ=33 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans-
64bit- FW- AGP3- Rate=x1,x2
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
        Capabilities: [90] Power Management version 1
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel modules: tridentfb

Comment 6 Dave Airlie 2008-02-19 01:27:43 EST
http://koji.fedoraproject.org/scratch/airlied/task_440049/

Can you try those packages? please force upgrade the last one I gave you as I
didn't renumber the package..

Comment 7 Alex Lancaster 2008-02-19 01:45:51 EST
Created attachment 295266 [details]
new /var/log/Xorg.0.log

Thanks.  startx now works, but it seems to start up in 800x600 mode by default.
 

I then ran system-config-display and switch to use a 1024x768 LCD Screen in the
"Monitor" tab, to get the 1024x768 mode, but this seems to defeat the purpose
of the autoconfiguration of X which should use the highest resolution possible
(1024x768 on this card).

In any case, at least it now works!
Comment 8 Alex Lancaster 2008-02-19 01:46:48 EST
(In reply to comment #7)
> I then ran system-config-display and switch to use a 1024x768 LCD Screen in the
> "Monitor" tab, to get the 1024x768 mode, but this seems to defeat the purpose
> of the autoconfiguration of X which should use the highest resolution possible
> (1024x768 on this card).

I also had to restart X to get the 1024x768 mode to appear.
Comment 9 Alex Lancaster 2008-02-19 01:54:07 EST
Hmm, I guess it automatically dropped down to 800x600 because of lack of video
memory, but 1024x768 does work if you drop the color depth to 16.  I would have
thought the driver should prefer the higher resolution and drop the color depth
to maximise the resolution, but this is not how it works?
Comment 10 Dave Airlie 2008-02-19 02:53:06 EST
okay I'll close this bug as this is a new issue, can you please file a new bug
for the autoconfig problem it appears the code that works out the max mode from
the VRAM size has some failings for your situation.

Note You need to log in before you can comment on or make changes to this bug.