Bug 433423 - [trident] driver doesn't select the maximum resolution available
[trident] driver doesn't select the maximum resolution available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-trident (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On: 433254
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 03:21 EST by Alex Lancaster
Modified: 2009-07-14 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log showing the server's attempt to detect default video settings. 2008-04-04 (34.14 KB, text/plain)
2008-04-04 22:20 EDT, Ira Malinich
no flags Details

  None (edit)
Description Alex Lancaster 2008-02-19 03:21:38 EST
+++ This bug was initially created as a clone of Bug #433254 +++

The trident driver seems to start up in 800x600 mode by default.
 
I then ran system-config-display and switch to use a 1024x768 LCD Screen in the
"Monitor" tab, to get the 1024x768 mode, but this seems to defeat the purpose
of the autoconfiguration of X which should use the highest resolution possible
(1024x768 on this card). I also had to restart X to get the 1024x768 mode to appear.

My guess is that it automatically drops down to 800x600 because of lack of video
memory, but 1024x768 does work if you drop the color depth to 16.  I would have
thought the driver should prefer the higher resolution and drop the color depth
to maximise the resolution, but this is not how it works?

-- Additional comment from airlied@redhat.com on 2008-02-19 02:53 EST --
okay I'll close this bug as this is a new issue, can you please file a new bug
for the autoconfig problem it appears the code that works out the max mode from
the VRAM size has some failings for your situation.
Comment 1 Dave Airlie 2008-03-13 00:19:25 EDT
http://koji.fedoraproject.org/scratch/airlied/task_514493/

there are some trident pkgs there.. can you see if the do what you expect when
you have no xorg.conf...
Comment 2 Alex Lancaster 2008-03-13 03:17:25 EDT
I downloaded the trident package above and then tried moving the xorg.conf
aside, but X currently won't start without a xorg.conf because of a (possibly
unrelated) bug in xorg-x11-xserver: bug #436684
As detailed on that bug I can get X to work if manually edit the xorg.conf to
use the "vesa" driver.

In any case, I tried running system-config-display to see if it would start the
vesa driver by default, but I now get (yet) another bug:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 27, in <module>
    import xf86config
  File "/usr/lib/python2.5/site-packages/xf86config.py", line 1, in <module>
    import ixf86config
ImportError: /usr/lib/python2.5/site-packages/ixf86configmodule.so: undefined
symbol: xf86freeInputrefList

I'll wait until the new xorg-x11-server is pushed to rawhide and then retest
then as X is pretty well broken at this point it seems.
Comment 3 Alex Lancaster 2008-03-13 03:38:32 EDT
OK, I manually installed xorg-x11-server-Xorg-1.4.99.901-6.20080310.fc9.i386:

http://koji.fedoraproject.org/koji/buildinfo?buildID=42769

and that gets the trident driver working again.  Then I moved aside the
xorg.conf and restarted, but it still defaults to 800x600. I still can't use
system-config-display to fix this manually, but that's another issue.
Comment 4 Matěj Cepl 2008-03-13 11:40:30 EDT
That would be system-config-display bug. Otherwise, this bug seems to be ready
to be closed.
Comment 5 Alex Lancaster 2008-03-13 11:57:08 EDT
(In reply to comment #4)
> That would be system-config-display bug. Otherwise, this bug seems to be ready
> to be closed.

Um, no as comment #3 indicates, it still defaults to too low a resolution (which
was the original bug).  I was simply saying that I couldn't work around it using
s-c-d.
Comment 6 Ira Malinich 2008-04-04 22:20:47 EDT
Created attachment 301356 [details]
Xorg log showing the server's attempt to detect default video settings.  2008-04-04
Comment 7 Ira Malinich 2008-04-04 22:21:19 EDT
I'm seeing this too with up-to-date Rawhide.  It can't seem to detect a
resolution higher than 800x600 at 24 bpp.  It worked with the same hardware in
Fedora 7.

Hardware:
Toshiba Satellite Pro 4600
Trident CyberBlade/XP graphics with (I think) 10 MB VRAM

Software:
xorg-x11-drv-trident-1.3.0-1.fc9.i386
xorg-x11-server-Xorg-1.4.99.901-16.20080401.fc9.i386

Any more useful info I'm missing?
Comment 8 Bug Zapper 2008-05-14 01:16:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-06-09 19:35:16 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 12:45:25 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.