Bug 433315 - Problem with rarian-compat post install script
Problem with rarian-compat post install script
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rarian (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 455240 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 11:13 EST by Orion Poplawski
Modified: 2008-10-15 22:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 12:53:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-02-18 11:13:54 EST
Description of problem:

could not open /etc/xml/catalog for saving
add command failed
could not open /etc/xml/catalog for saving
add command failed
error: %post(rarian-compat-0.6.0-3.fc8.i386) scriptlet failed, exit status 2

%post scripts should not fail, and should not generate output.

Suggestions:

- rarian-compat should %Require(post): xml-common
- Change commands to be like:

/usr/bin/xmlcatalog --noout --add "rewriteSystem" \
 
"http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd"
\
  "/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd" $CATALOG >& /dev/null || :



Version-Release number of selected component (if applicable):
rarian-compat-0.6.0-3.fc8
Comment 1 Matthew Barnes 2008-02-18 12:53:47 EST
Folding this into bug #433268.  Already fixed this for Rawhide, though I missed
the /dev/null part.

*** This bug has been marked as a duplicate of 433268 ***
Comment 2 Matthew Barnes 2008-09-17 10:35:34 EDT
*** Bug 455240 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2008-09-17 11:03:18 EDT
rarian-0.6.0-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/rarian-0.6.0-4.fc8
Comment 4 Fedora Update System 2008-10-15 22:04:17 EDT
rarian-0.6.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.