Bug 433268 - rarian-compat spec file dep problem
rarian-compat spec file dep problem
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rarian (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 443603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 03:56 EST by Rudolf Kastl
Modified: 2008-10-15 22:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 11:09:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2008-02-18 03:56:21 EST
Description of problem:
actually uninstalling fails under some conditions because the scriptlets use
xmlcatalog from the libxml2 package without having libxml2 package added as
dependency (scriptlet) in the specfile

Version-Release number of selected component (if applicable):
rarian-compat

Steps to reproduce:
rpm -e rarian-compat on a minimal rawhide install fails with postscriptlet error
xmlcatalog not found :)
Comment 1 Matthew Barnes 2008-02-18 11:09:50 EST
The package already has

   Requires: libxml2

but I think it needs to be

   Requires(post): libxml2
   Requires(postun): libxml2

Should be fixed in rarian-0.7.1-3.fc9.

I haven't actually tested this so feel free to reopen this bug if the update
does not resolve the issue.
Comment 2 Matthew Barnes 2008-02-18 12:53:48 EST
*** Bug 433315 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Barnes 2008-02-18 12:54:52 EST
Bug #433315 suggested adding ">& /dev/null || :" to the end of the xmlcatalog
commands.  Will include this in the next update.
Comment 4 Matthew Barnes 2008-05-19 13:42:56 EDT
*** Bug 443603 has been marked as a duplicate of this bug. ***
Comment 5 Matthew Barnes 2008-09-17 10:44:45 EDT
Backported the fixes here to Fedora 8: rarian-0.6.0-4.fc8
Comment 6 Fedora Update System 2008-09-17 11:03:16 EDT
rarian-0.6.0-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/rarian-0.6.0-4.fc8
Comment 7 Fedora Update System 2008-10-15 22:04:11 EDT
rarian-0.6.0-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.