This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 433364 - Package Updater produces error when "view or update" slelected
Package Updater produces error when "view or update" slelected
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 16:04 EST by Matt Looney
Modified: 2014-01-21 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 16:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Looney 2008-02-18 16:04:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
Error in "actual results" comes up whenever I try to open the package updater application.

Version-Release number of selected component (if applicable):
yum-3.2.7-1.fc8, kernel-2.6.23.9-85.fc8

How reproducible:
Always


Steps to Reproduce:
1.package updater
2.view updates
3.

Actual Results:
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 610, in main
    pup.run()
  File "/usr/sbin/pup", line 449, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 267, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 331, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 296, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 63, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 77, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x884856c>
repos: ['atrpms', 'adobe', 'livna-development', 'updates-source', 'planetcore', 'livna-development-debuginfo', 'jpackage-generic', 'livna', 'updates-testing-source', 'livna-debuginfo', 'fedora', 'atrpms-testing', 'livna-source', 'InstallMedia', 'rpmforge', 'development-source', 'planetccrma', 'development', 'updates-debuginfo', 'fedora-debuginfo', 'jpackage-fedora', 'livna-development-source', 'updates-testing-debuginfo', 'updates', 'atrpms-bleeding', 'jpackage-nonfree', 'freshrpms', 'livna-testing', 'fedora-source', 'development-debuginfo', 'livna-testing-debug', 'updates-testing', 'kagesenshi', 'livna-testing-source']
repomirrors: {'InstallMedia': [], 'atrpms': ['http://dl.atrpms.net/f8-i386/atrpms/stable'], 'adobe': ['http://linuxdownload.adobe.com/linux/i386/'], 'fedora': ['http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os', 'ftp://ftp.uci.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.lib.ucdavis.edu/fedora/linux/releases/8/Everything/i386/os', 'ftp://mirror.colorado.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.cat.pdx.edu/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.facebook.com/linux/releases/8/Everything/i386/os', 'http://limestone.uoregon.edu/ftp/fedora/linux/releases/8/Everything/i386/os', 'http://linux.nssl.noaa.gov/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.steadfast.net/fedora/releases/8/Everything/i386/os', 'http://mirrors.usu.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.reflected.net/fedora/linux/releases/8/Everything/i386/os', 'http://www.gtlib.gatech.edu/pub/fedora.redhat/linux/releases/8/Everything/i386/os', 'ftp://mirror.nyi.net/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.iweb.ca/releases/8/Everything/i386/os', 'http://mirror.anl.gov/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.hiwaay.net/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.unl.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.web-ster.com/fedora/releases/8/Everything/i386/os', 'http://gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.cc.vt.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.ndlug.nd.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.usu.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.usf.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.linux.ncsu.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.software.umn.edu/linux/fedora/releases/8/Everything/i386/os', 'http://mirror.newnanutilities.org/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.stanford.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.nuvio.com/pub/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.applios.net/pub/fedora/linux/releases/8/Everything/i386/os'], 'livna': ['ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/8/i386/', 'http://rpm.livna.org/fedora/8/i386/', 'http://mirror.atrpms.net/livna/fedora/8/i386/', 'http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/8/i386/', 'http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/8/i386/', 'http://livna.cat.pdx.edu/fedora/8/i386/']}


Expected Results:
it should have shown updates available.

Additional info:
Comment 1 James Antill 2008-02-18 16:14:45 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.