Bug 433385 - "service setroubleshoot cleardb" removes the wrong database.xml file
Summary: "service setroubleshoot cleardb" removes the wrong database.xml file
Status: CLOSED DUPLICATE of bug 338071
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-18 22:52 UTC by JM
Modified: 2008-02-18 23:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 23:54:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description JM 2008-02-18 22:52:44 UTC
The command

service setroubleshoot cleardb

removes the wrong database.xml file, it tries to remove 

/var/lib/setroubleshoot/database.xml

but actually there is only a (at least on my system)

/var/lib/setroubleshoot/audit_listener_database.xml

so maybe a 

rm -f /var/lib/setroubleshoot/*database.xml

in the /etc/init.d/setroubleshoot  file works better?

The version of setroubleshoot is:

setroubleshoot-1.10.7-1.fc8
setroubleshoot-server-1.10.7-1.fc8
setroubleshoot-plugins-1.10.4-1.fc8

Comment 1 John Dennis 2008-02-18 23:54:19 UTC
FYI, the 2.0 versions of setroubleshoot are available for F-8 in updates-testing.

*** This bug has been marked as a duplicate of 338071 ***


Note You need to log in before you can comment on or make changes to this bug.