Bug 433412 - Error on boot from ip6tables after install
Error on boot from ip6tables after install
Status: CLOSED DUPLICATE of bug 431845
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 00:00 EST by Ray Todd Stevens
Modified: 2008-02-19 09:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 09:28:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the ip6tables config (1.76 KB, text/plain)
2008-02-19 00:04 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2008-02-19 00:00:58 EST
Description of problem:

I get a failure to load and an error from ip6tables during bootup without any
changes to it from the installed configuration

How reproducible:

Every time I boot, of course I only installed once.  I am doing a network install.

Here is a rerun for the load script so you can see the error.   Interestingly
enough the boot.log is blank.

[root@goldenchild log]# /etc/init.d/ip6tables restart
ip6tables: Flushing firewall rules:                        [  OK  ]
ip6tables: Setting chains to policy ACCEPT: filter         [  OK  ]
ip6tables: Unloading modules:                              [  OK  ]
ip6tables: Applying firewall rules: ip6tables-restore v1.3.8: Unknown arg
`--icmp-type'
Error occurred at line: 8
Try `ip6tables-restore -h' or 'ip6tables-restore --help' for more information.
                                                           [FAILED]
[root@goldenchild log]#
Comment 1 Ray Todd Stevens 2008-02-19 00:02:20 EST
Here is the ip6 tables

# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp --icmp-type any -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp6-adm-prohibited
-A FORWARD -j REJECT --reject-with icmp6-adm-prohibited
COMMIT
Comment 2 Ray Todd Stevens 2008-02-19 00:04:21 EST
Created attachment 295259 [details]
Here is the ip6tables config
Comment 3 Ray Todd Stevens 2008-02-19 00:06:14 EST
If it helps any I am not actually using ip6, and would normally not have worried
about this, but we are testing this stuff right now.   I have several interfaces
in this machine all ethernet.   Only eth0 is in use for ip4 and is dchp configed.
Comment 4 Thomas Woerner 2008-02-19 09:28:33 EST

*** This bug has been marked as a duplicate of 431845 ***

Note You need to log in before you can comment on or make changes to this bug.