Bug 433469 - evolution-exchange crashes when attempting to authenticate
evolution-exchange crashes when attempting to authenticate
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 433648
  Show dependency treegraph
 
Reported: 2008-02-19 09:50 EST by James
Modified: 2008-02-20 18:43 EST (History)
0 users

See Also:
Fixed In Version: evolution-data-server-1.12.3-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 18:43:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Censored Bug Buddy report from evolution-exchange crash (9.87 KB, text/plain)
2008-02-19 09:50 EST, James
no flags Details

  None (edit)
Description James 2008-02-19 09:50:34 EST
Description of problem:
The evolution-exchange plugin crashes during the "Autheticate" stage of setting
up an account.

Version-Release number of selected component (if applicable):
evolution-exchange-2.12.3-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Set up an e-mail account for a mailbox on an Exchange server.
2. Fill out the OWA URL, click Authenticate.
3. Enter password.
  
Actual results:
Evolution crashed.

Expected results:
Access to mailbox.

Additional info:
See Bug Buddy report attached.
Comment 1 James 2008-02-19 09:50:34 EST
Created attachment 295290 [details]
Censored Bug Buddy report from evolution-exchange crash
Comment 2 Matthew Barnes 2008-02-20 10:34:11 EST
Looks like libsoup is choking on a URI it doesn't like and Evolution is not
checking for error.  This appears to have been fixed in Evolution 2.21 so I can
backport the fix.
Comment 3 Matthew Barnes 2008-02-20 11:28:15 EST
James, I built an updated evolution-data-server package with a patch based on
your  Bug Buddy report, but I haven't been able to reproduce the crash here so
the patch is untested.  Would you mind testing the package before I push it to
Fedora repos?

Updated package is here:
http://koji.fedoraproject.org/packages/evolution-data-server/1.12.3/3.fc8
Comment 4 James 2008-02-20 11:51:45 EST
Thanks, it no longer crashes.
Comment 5 Matthew Barnes 2008-02-20 12:04:30 EST
Cool, I'll push it out to Fedora Updates then.

I'm still trying to reproduce this on our internal Exchange servers here but the
Authenticate step is working fine here.  I suspect it's related to your Outlook
Web Access configuration.  Do you know anything about it, or whether it's some
kind of non-standard configuration?
Comment 6 Fedora Update System 2008-02-20 12:07:06 EST
evolution-data-server-1.12.3-3.fc8 has been submitted as an update for Fedora 8
Comment 8 James 2008-02-20 13:09:22 EST
Could well be. There's been this push where I am to put everything on Exchange
2007 so I thought I'd give it go. The local admins haven't published any config
info and I've not managed to get it to *work* yet (there's talk of getting
Brutus involved; with http://www.outlook.XXXXX.ac.uk/exchange it cannot find
Exchange EWS, with https the username/password is rejected), but at least now
handling an error condition properly!
Comment 9 Matthew Barnes 2008-02-20 13:36:58 EST
Ah okay.  Evolution does not yet support Exchange 2007 at all.  It's being
worked on feverishly and should be stable by Fedora 10.  Test packages for
Fedora 8 are available at [1] but should be considered extremely unstable.

[1]
http://download.opensuse.org/repositories/home:/jjohnny:/evolution-exchange-mapi-provider/

Note You need to log in before you can comment on or make changes to this bug.