Bug 433476 - Update ImageMagick before F9
Update ImageMagick before F9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 432885 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 10:40 EST by Sammy
Modified: 2008-04-27 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-27 15:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ImageMagick spec file (22.22 KB, text/plain)
2008-02-19 10:41 EST, Sammy
no flags Details
New ImageMagick multilib patch (2.43 KB, patch)
2008-02-19 10:42 EST, Sammy
no flags Details | Diff
patch for octave-forge to work with new ImageMagick (832 bytes, patch)
2008-02-19 10:43 EST, Sammy
no flags Details | Diff
patch for transcode for new ImageMagick (635 bytes, patch)
2008-02-19 10:44 EST, Sammy
no flags Details | Diff
dx patch for new imagemagick (2.14 KB, patch)
2008-02-20 09:25 EST, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2008-02-19 10:40:45 EST
Latest ImageMagick package 6.3.8.9 (and few earlier releases) change
the location of Magick includes directory and names of the library
files. Programs depending on the runtime libraries will have to be
rebuilt. If those programs use pkgconfig then there is no problem.
Otherwise they will have to be patched to find the correct includes
and libraries. I have done this partially. I will attach a modified
spec file.

Among the packages I am using I found the following conflicts:

1. transcode from livna (had to be patched)
2. xine-lib (worked fine by just recompiling)
3. octave-forge (had to be patched)

Since this may involve other packages that I do not have it may be better
to do the upgrade before F9 is released since it may be harder to upgrade
a released product with these changes. I will also attach the patches I
used for the other packages here.
Thanks
Comment 1 Sammy 2008-02-19 10:41:37 EST
Created attachment 295300 [details]
ImageMagick spec file
Comment 2 Sammy 2008-02-19 10:42:09 EST
Created attachment 295301 [details]
New ImageMagick multilib patch
Comment 3 Sammy 2008-02-19 10:43:31 EST
Created attachment 295302 [details]
patch for octave-forge to work with new ImageMagick
Comment 4 Sammy 2008-02-19 10:44:57 EST
Created attachment 295303 [details]
patch for transcode for new ImageMagick
Comment 5 Sammy 2008-02-20 09:25:18 EST
Sorry, forgot the dx package. This also needs to be rebuilt. It needs the
following lines in the spec file build section before configure:

CFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/ImageMagick" \
CXXFLAGS="${RPM_OPT_FLAGS} -I%{_includedir}/ImageMagick"

and the attached patch.
Comment 6 Sammy 2008-02-20 09:25:43 EST
Created attachment 295418 [details]
dx patch for new imagemagick
Comment 7 Hans de Goede 2008-04-26 02:14:24 EDT
Quick intro: I'm now a comaintainer of ImageMagick, and thus going through all
the open bugs.

Thanks for the patches, unfortunately its too late to do this now before F-9, as
the soname's change, so thats way to much churn while in the final freeze.

I'll prepare an update to the latest upstream version for the F-10 cycle.
Comment 8 Sammy 2008-04-26 07:58:11 EDT
I understand! Thanks.
Comment 9 Hans de Goede 2008-04-26 16:44:38 EDT
*** Bug 432885 has been marked as a duplicate of this bug. ***
Comment 10 Hans de Goede 2008-04-27 15:52:16 EDT
6.4.0.10-1 will show up in rawhide as soon as it unfreezes from the final F-9
freeze, closing.

In the mean time, you can download it and test it here if you want:
http://koji.fedoraproject.org/koji/taskinfo?taskID=585045

Note You need to log in before you can comment on or make changes to this bug.