This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 433512 - need a yum plugin to auto-install langpacks for kde, openoffice, etc
need a yum plugin to auto-install langpacks for kde, openoffice, etc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jens Petersen
Bill Nottingham
: FutureFeature, i18n
: 475127 (view as bug list)
Depends On: 536737
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 14:22 EST by Daniel Laskowski
Modified: 2014-03-16 23:12 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 21:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Laskowski 2008-02-19 14:22:28 EST
Description of problem:
yum doesn't install kde-i18n-[language] with installation of first KDE/QT
application.

Steps to Reproduce:
1. Fresh, default Fedora 8 installation (without any KDE application) in Polish
language
2. Install some KDE application (for example krusader)
yum output:
=============================================================================

 Package                 Arch       Version          Repository        Size 

=============================================================================

Installing:

 krusader                i386       1.80.0-2.fc8     fedora            3.1 M

Installing for dependencies:

 OpenEXR-libs            i386       1.6.1-3.fc8      updates           252 k

 arts                    i386       8:1.5.8-4.fc8    fedora            1.2 M

 avahi-qt3               i386       0.6.21-8.fc8     updates            19 k

 fedorainfinity-kdm-theme  noarch     1.0.4-1.fc8      updates           1.1 M

 htdig                   i386       3:3.2.0b6-13.fc8  updates           1.0 M

 ilmbase                 i386       1.0.1-1.fc8      updates           118 k

 jack-audio-connection-kit  i386       0.103.0-5.fc8    updates           139 k

 kde-filesystem          noarch     4-6.fc8          updates            17 k

 kde-settings            noarch     3.5-36.fc8.1     updates            15 k

 kde-settings-kdm        noarch     3.5-36.fc8.1     updates            17 k

 kdebase                 i386       6:3.5.8-32.fc8   updates            27 M

 kdebase-libs            i386       6:3.5.8-32.fc8   updates           1.0 M

 kdebindings             i386       3.5.8-1.fc8      fedora            9.2 M

 kdelibs                 i386       6:3.5.8-19.fc8   updates            17 M

 kdnssd-avahi            i386       0.1.3-0.2.20060713svn.fc8  fedora          
  44 k

 libfreebob              i386       1.0.3-1.fc7      fedora            154 k

 nas                     i386       1.9.1-2.fc8      updates           647 k

 qt                      i386       1:3.3.8-9.fc8    fedora            3.5 M

 ruby-libs               i386       1.8.6.111-1.fc8  updates           1.7 M

 xorg-x11-xdm            i386       1:1.1.6-2.fc8    fedora            137 k



Transaction Summary

=============================================================================

Install     21 Package(s)         

Update       0 Package(s)         

Remove       0 Package(s)         



Total download size: 68 M


3. Start KDE application (for example Konqueror) -> it will be in English language
  
Actual results:
Installed KDE/QT are in English language, not in system default (in my system -
Polish)

Expected results:
yum should install package kde-i18n-[language] too (according to system language
settings).

In Ubuntu is the same problem:
https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/69684 
But in Ubuntu when I open language selection in Gnome menu – there will be
message that not all language files are installed and then system will install
missing files automaticly.

In Fedora after start system-config-language -> nothing happend...
I must install kde-i18n-Polish manually.
Comment 1 Pravin Satpute 2008-06-19 03:46:54 EDT
It looks like bug with comps file
Comment 2 Jens Petersen 2008-06-19 04:09:00 EDT
Daniel, if you have a chance to try - is it better with F9?
Comment 3 Jens Petersen 2008-07-04 02:23:08 EDT
Best way to do this is to specify two yum groups at once:

# yum group install kde-desktop polish-support

or install the groups in that order.

Does that help?
Comment 4 Daniel Laskowski 2008-07-04 07:15:26 EDT
I installed default F9 + yum update + livna (nVidia).
Then I installed two QT/KDE applications: smplayer and krusader.
Both are in Polish language, so It's good. But not all KDE components are in
Polish - for example when I open file properties in krusader.

I'm on holidays - I will check it better when I back.

@Comment #3 From Jens Petersen
"# yum group install kde-desktop polish-support"

But it install all KDE environment, doesn't it?
Comment 5 Jens Petersen 2008-07-07 00:56:05 EDT
(In reply to comment #4)
> Then I installed two QT/KDE applications: smplayer and krusader.
> Both are in Polish language, so It's good. But not all KDE components are in
> Polish - for example when I open file properties in krusader.



> @Comment #3 From Jens Petersen
> "# yum group install kde-desktop polish-support"
> 
> But it install all KDE environment, doesn't it?

Right so after installing you applications you can run
"yum groupinstall polish-support".
Comment 6 Jens Petersen 2008-07-31 01:47:09 EDT
Probably a yum plugin could help with this and langpacks for other apps too.
Comment 7 Daniel Laskowski 2008-07-31 11:40:04 EDT
(In reply to comment #5)
> Right so after installing you applications you can run
> "yum groupinstall polish-support".

True. After installing that group - everything is OK.
But it should be done by yum automaticly when I installed krusader...
Comment 8 Tony Fu 2008-09-09 23:15:33 EDT
requested by Jens Petersen (#27995)
Comment 9 Bug Zapper 2008-11-25 21:07:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Jens Petersen 2009-01-21 04:15:38 EST
Bill recently posted an initial prototype to fedora-devel-list:

https://www.redhat.com/archives/fedora-devel-list/2009-January/msg00882.html
Comment 11 Jens Petersen 2009-01-21 04:16:53 EST
*** Bug 475127 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2009-01-21 13:24:38 EST
Re: the duplicated bug, the plugin wouldn't work for that as it's currently written, as it's only for adding packages where the language code is part of the package name. It doesn't handle all conditional cases in comps.
Comment 13 Jens Petersen 2009-01-21 19:19:54 EST
Yep sure, but I think it could be expanded with some work to cover most required cases.
(I just followed up belatedly to your original post on fedora-devel-list too.)
Comment 14 Jens Petersen 2009-05-22 03:35:26 EDT
Creating https://fedoraproject.org/wiki/Features/YumLangpackPlugin for this.
Comment 15 Jens Petersen 2009-11-15 20:20:29 EST
yum-langpacks submitted for package review: bug 536737.
Comment 16 Jens Petersen 2010-01-06 21:37:13 EST
yum-langpacks is now in rawhide please try it out.

Note You need to log in before you can comment on or make changes to this bug.