Bug 433526 - rpm, with unexpected arguments, segfaults
rpm, with unexpected arguments, segfaults
Status: CLOSED DUPLICATE of bug 433324
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 15:30 EST by Michal Jaegermann
Modified: 2008-02-20 01:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 01:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-02-19 15:30:28 EST
Description of problem:

I made a mistake and instead of typing 'rpmbuild -ba some.spec'
I did
            rpm -ba some.spec

and in a response I got "Segmentation fault".

With limits on cores lifted that immediately produces a core file
and looking on it with gdb (no debugging symbols loaded) the following
backtrace appears:

Program terminated with signal 11, Segmentation fault.
#0  0x00007f17a492c480 in strlen () from /lib64/libc.so.6
(gdb) where
#0  0x00007f17a492c480 in strlen () from /lib64/libc.so.6
#1  0x00007f17a48f5166 in vfprintf () from /lib64/libc.so.6
#2  0x00007f17a48f6460 in buffered_vfprintf () from /lib64/libc.so.6
#3  0x00007f17a48f1886 in vfprintf () from /lib64/libc.so.6
#4  0x00007f17a49a5f12 in __fprintf_chk () from /lib64/libc.so.6
#5  0x0000000000404aaa in ?? ()
#6  0x00007f17a48c836a in __libc_start_main () from /lib64/libc.so.6
#7  0x00000000004034d9 in ?? ()
#8  0x00007fffadc521b8 in ?? ()
#9  0x000000000000001c in ?? ()
#10 0x0000000000000003 in ?? ()
#11 0x00007fffadc527e4 in ?? ()
#12 0x00007fffadc527e8 in ?? ()
#13 0x00007fffadc527ec in ?? ()
#14 0x0000000000000000 in ?? ()

With installed rpm-debuginfo the picture is slightly different

(gdb) where
#0  0x00007f17a492c480 in strlen () from /lib64/libc.so.6
#1  0x00007f17a48f5166 in vfprintf () from /lib64/libc.so.6
#2  0x00007f17a48f6460 in buffered_vfprintf () from /lib64/libc.so.6
#3  0x00007f17a48f1886 in vfprintf () from /lib64/libc.so.6
#4  0x00007f17a49a5f12 in __fprintf_chk () from /lib64/libc.so.6
#5  0x0000000000404aaa in main (argc=3, argv=<value optimized out>)
    at /usr/include/bits/stdio2.h:98
#6  0x00007f17a48c836a in __libc_start_main () from /lib64/libc.so.6
#7  0x00000000004034d9 in _start ()
(gdb) f 5
#5  0x0000000000404aaa in main (argc=3, argv=<value optimized out>)
    at /usr/include/bits/stdio2.h:98
warning: Source file is more recent than executable.
98        return __fprintf_chk (__stream, __USE_FORTIFY_LEVEL - 1, __fmt,

It really does not matter what spec file is given and if corresponding
sources are even available.  Cores are dumped right away.

The worry, of course, is what other non-valid or valid flags combinations
will have the same effect.

Version-Release number of selected component (if applicable):
rpm-4.4.2.3-0.1.rc1

How reproducible:
Every time.
Comment 1 Panu Matilainen 2008-02-20 01:33:41 EST
Latest popt is busted...

*** This bug has been marked as a duplicate of 433324 ***

Note You need to log in before you can comment on or make changes to this bug.