Bug 433324 - popt: crash in POPT_fprintf e.g. rpm/ipcalc usage
popt: crash in POPT_fprintf e.g. rpm/ipcalc usage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
: 433526 435832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 12:27 EST by Caolan McNamara
Modified: 2008-03-04 01:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.13-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 16:07:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (1.47 KB, text/plain)
2008-02-18 12:28 EST, Caolan McNamara
no flags Details

  None (edit)
Description Caolan McNamara 2008-02-18 12:27:00 EST
> rpm -q popt
popt-1.13-1.fc9.x86_64
> ipcalc
ipcalc: ip address expected
Usage: ipcalc [OPTION...]
  -b, --broadcast     Display calculated broadcast address
  -h, --hostname      Show hostname determined via DNS
  -m, --netmask       Display default netmask for IP (class A, B, or C)
  -n, --network       Display network address
  -p, --prefix        Display network prefix
  -s, --silent        Don't ever display error messages

Help options:
  -?, --help          Show this help message
  --usage             Display brief usage message
> rpm -q popt
popt-1.13-2.fc9.x86_64
> ipcalc
ipcalc: ip address expected
Segmentation fault
Comment 1 Caolan McNamara 2008-02-18 12:28:07 EST
Created attachment 295182 [details]
backtrace
Comment 2 Panu Matilainen 2008-02-20 01:33:41 EST
*** Bug 433526 has been marked as a duplicate of this bug. ***
Comment 3 Robert Scheck 2008-02-20 02:23:49 EST
Fix is around the corner.
Comment 4 Robert Scheck 2008-02-20 04:50:00 EST
https://www.redhat.com/archives/fedora-devel-list/2008-February/msg01685.html has 
to be solved first in order to get a new working popt package built - sorry.
Comment 5 Robert Scheck 2008-02-20 16:07:43 EST
Package: popt-1.13-3.fc9
Tag: dist-f9
Status: complete
Built by: robert
ID: 38018
Started: Wed, 20 Feb 2008 13:00:51 MST
Finished: Wed, 20 Feb 2008 13:10:45 MST
Comment 6 Panu Matilainen 2008-03-04 01:10:42 EST
*** Bug 435832 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.