Bug 433529 - vnc server through krfb and accessing by http broken
vnc server through krfb and accessing by http broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdenetwork (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Ngo Than
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 16:02 EST by Jeff Bastian
Modified: 2013-04-12 15:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 09:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
corrected /usr/bin/krfb_httpd script (884 bytes, application/octet-stream)
2008-02-19 16:02 EST, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2008-02-19 16:02:36 EST
+++ This bug was initially created as a clone of Bug #433493 +++

This is a clone of bug 433493, bug 433510, and bug 433511 for RHEL 5.1.

The /usr/bin/krfb_httpd script is really odd in RHEL 5.1 
  kdenetwork-3.5.4-4.fc6

It looks like a DOS file (lots of ^M chars instead of newlines), but running
dos2unix does not clean it up.  Doing '%s/^M/\r/g' with vim cleans it up nicely,
though.

It also has the wrong <APPLET> tag.  It should be
  <APPLET CODE=vncviewer/VNCViewer.class ARCHIVE=vncviewer.jar ....
Comment 1 Jeff Bastian 2008-02-19 16:02:36 EST
Created attachment 295333 [details]
corrected /usr/bin/krfb_httpd script
Comment 2 Jeff Bastian 2008-02-22 12:40:11 EST
(In reply to comment #0)
> Doing '%s/^M/\r/g' with vim cleans it up nicely, though.

This cleans it up a little too much.  Three ^M chars need to remain for the
script to work.  The attachment in comment #1 does have 3 ^M chars in it.

This is probably what caused bug 433510 in Fedora 8...
Comment 3 Phil Knirsch 2008-04-30 10:42:19 EDT
Proposing for RHEL-5.3, waiting with final ACK on developer review.

Read ya, Phil 
Comment 12 errata-xmlrpc 2009-04-29 09:39:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0452.html

Note You need to log in before you can comment on or make changes to this bug.