This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 433654 - cannot create KVM guests with shared networking
cannot create KVM guests with shared networking
Status: CLOSED DUPLICATE of bug 435506
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 13:04 EST by James Ralston
Modified: 2008-03-19 14:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 14:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen of virt-manager showing inability to select a shared physical network device (82.28 KB, image/png)
2008-02-20 13:04 EST, James Ralston
no flags Details

  None (edit)
Description James Ralston 2008-02-20 13:04:15 EST
I am attempting to create a KVM guest on my Fedora 8 system, using
virt-manager-0.5.3-1.fc8.  Because the guest must be visible to other hosts on
the (physical) network, I must connect the guest to the host network via a
shared physical device.

However, per the attached screenshot, the option to select eth0 (the only
network interface in the host) is grayed out with the explanation of "(not
bridged)".

I did some digging, and found the KVM HOWTO section on Networking:

http://kvm.qumranet.com/kvmwiki/Networking

Apparently, neither virt-manager (nor anything else) properly performs the steps
needed to set up the bridge.

However, when I execute the commands that the HOWTO recommends:

# brctl addbr br0
# brctl addif br0 eth0

...all network traffic through eth0 ceases after the addif step.  This isn't a
SELinux or firewall issue, because the addif step kills all eth0 traffic even
when it SELinux running in permissive mode and the firewall isn't running.

There is little information to track down what the problem is.  The addbr
command causes this message to appear in syslog:

Feb 20 12:47:23 example kernel: br0: Dropping NETIF_F_UFO since no
NETIF_F_HW_CSUM feature.

The addif step causes:

Feb 20 12:47:34 example kernel: device eth0 entered promiscuous mode

But that's it.  There's no clue as to what the problem might be.  So,
effectively, it is impossible to create a KVM guest that connects to the host
network via a shared physical device using.

I realize that virt-manager is a work in progress but this, alas, is a pretty
glaring deficiency.  :(

Until virt-manager can perform the right actions behind the scenes, can anyone
point me to an explanation of exactly what I need to do to get host networking
via a shared physical device working?  The only explanations I have been able to
find via Google (e.g., the KVM HOWTO) are incomplete and/or wrong.
Comment 1 James Ralston 2008-02-20 13:04:15 EST
Created attachment 295435 [details]
screen of virt-manager showing inability to select a shared physical network device
Comment 2 Jonathan Boulle 2008-03-17 20:09:51 EDT
Seconded with virt-manager-0.5.3-1.fc8 - completely unable to share physical
device with KVM guests.
Comment 3 Daniel Berrange 2008-03-19 14:40:17 EDT

*** This bug has been marked as a duplicate of 435506 ***

Note You need to log in before you can comment on or make changes to this bug.