Bug 435506 - virt-manager shows no shared interfaces - just a long line in the middile of the drop down box.
virt-manager shows no shared interfaces - just a long line in the middile of ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
: 433654 437194 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-29 14:44 EST by Steven Foster
Modified: 2008-03-26 13:16 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.5.3-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows line on the drop down (34.09 KB, image/png)
2008-02-29 14:48 EST, Steven Foster
no flags Details

  None (edit)
Description Steven Foster 2008-02-29 14:44:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
After patching my Fedora 8 system (patches were autoinstalled) - This morning I rebooted and tried to create a new qemu-kvm guest using virt-manager.

Not able to complete shared physical device, and noted these errors.

[Fri, 29 Feb 2008 11:22:34 virt-manager 6797] INFO (virt-manager:126) Application startup
[Fri, 29 Feb 2008 11:22:35 virt-manager 6798] DEBUG (engine:74) About to connect to uris ['qemu:///system', 'xen:///']
[Fri, 29 Feb 2008 11:22:35 virt-manager 6798] ERROR (connection:158) Unable to connect to HAL to list network devices: '%s'<class 'dbus.exceptions.DBusException'> org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "QueryCapability" error name "(unset)" destination ":1.4")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 153, in detect_network_devices
    self._device_added(path)
  File "/usr/share/virt-manager/virtManager/connection.py", line 164, in _device_added
    if obj.QueryCapability("net"):
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 63, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 135, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 603, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "QueryCapability" error name "(unset)" destination ":1.4")

[Fri, 29 Feb 2008 11:22:35 virt-manager 6798] ERROR (connection:158) Unable to connect to HAL to list network devices: '%s'<class 'dbus.exceptions.DBusException'> org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "QueryCapability" error name "(unset)" destination ":1.4")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 153, in detect_network_devices
    self._device_added(path)
  File "/usr/share/virt-manager/virtManager/connection.py", line 164, in _device_added
    if obj.QueryCapability("net"):
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 63, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 135, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 603, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "(unset)" member "QueryCapability" error name "(unset)" destination ":1.4")



Version-Release number of selected component (if applicable):
virt-manager-0.5.3-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Try to use the physical device drop down box.
2.
3.

Actual Results:
long line thru the drop down space.

Expected Results:
A listing of available shared devices.

Additional info:
Comment 1 Steven Foster 2008-02-29 14:48:50 EST
Created attachment 296406 [details]
Shows line on the drop down
Comment 2 Steven Foster 2008-03-01 02:11:33 EST
These were the the yum updates applied - I see that dbus got updated.

Maybe a culprit?

Feb 29 08:01:58 amdquad yum: Updated: coreutils - 6.9-13.fc8.x86_64
Feb 29 08:01:59 amdquad yum: Updated: xen-libs - 3.1.2-2.fc8.x86_64
Feb 29 08:02:02 amdquad yum: Updated: selinux-policy - 3.0.8-87.fc8.noarch
Feb 29 08:02:03 amdquad yum: Updated: gmp - 4.2.2-4.fc8.x86_64
Feb 29 08:02:13 amdquad yum: Updated: selinux-policy-targeted - 3.0.8-87.fc8.noarch
Feb 29 08:02:14 amdquad yum: Updated: libsilc - 1.0.2-5.fc8.x86_64
Feb 29 08:02:14 amdquad yum: Updated: kvm - 60-3.fc8.x86_64
Feb 29 08:02:16 amdquad yum: Updated: qemu - 0.9.0-7.fc8.x86_64
Feb 29 08:02:28 amdquad yum: Updated: selinux-policy-devel - 3.0.8-87.fc8.noarch
Feb 29 08:02:30 amdquad yum: Updated: logwatch - 7.3.6-15.fc8.noarch
Feb 29 08:02:30 amdquad yum: Updated: xen-libs - 3.1.2-2.fc8.i386
Feb 29 08:02:32 amdquad yum: Updated: xen - 3.1.2-2.fc8.x86_64
Feb 29 08:02:33 amdquad yum: Updated: xen-devel - 3.1.2-2.fc8.x86_64
Feb 29 08:02:33 amdquad yum: Updated: xen-devel - 3.1.2-2.fc8.i386
Feb 29 08:02:34 amdquad yum: Updated: dbus - 1.1.2-9.fc8.x86_64
Feb 29 08:02:34 amdquad yum: Updated: dbus-libs - 1.1.2-9.fc8.x86_64
Feb 29 08:02:37 amdquad yum: Updated: setroubleshoot-plugins - 2.0.4-3.fc8.noarch
Feb 29 08:02:40 amdquad yum: Updated: setroubleshoot - 2.0.5-2.fc8.noarch
Feb 29 08:02:40 amdquad yum: Updated: setroubleshoot-server - 2.0.5-2.fc8.noarch
Feb 29 08:02:40 amdquad yum: Updated: dbus-x11 - 1.1.2-9.fc8.x86_64
Feb 29 08:02:41 amdquad yum: Updated: dbus-libs - 1.1.2-9.fc8.i386
Comment 3 Steven Foster 2008-03-01 16:52:09 EST
It WAS the dbus packages....  Reverting the dbus packages to the original
version on the Distro DVD restores functionality....
Comment 4 Steven Foster 2008-03-01 16:53:14 EST
Or at least back to function as delivered.
Comment 5 Daniel Berrange 2008-03-19 14:40:09 EDT
*** Bug 437194 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Berrange 2008-03-19 14:40:18 EDT
*** Bug 433654 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-03-19 14:56:37 EDT
virt-manager-0.5.3-2.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-03-21 18:12:04 EDT
virt-manager-0.5.3-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2604
Comment 9 Fedora Update System 2008-03-26 13:16:32 EDT
virt-manager-0.5.3-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.