Bug 433711 - Mouse does not focus to guest console when opening it
Mouse does not focus to guest console when opening it
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Martin Jenner
: Regression
: 435786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-20 17:35 EST by Don Dutile
Modified: 2010-10-22 18:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHEA-2008-0370
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dutile 2008-02-20 17:35:33 EST
Description of problem:
When starting up a FV guest on 2.6.18-63.el5xen, using virt-manager (open a
selected guest, hit Run button), the mouse will not focus on the window unless
CTL-ALT is entered on the keyboard.

Version-Release number of selected component (if applicable):
kernel: 2.6.18-63.el5xen,
virt-manager: 0.5.3-2.el5
gtk-vnc: 0.3.2-1.el5

How reproducible:
Every time I start a rhel4 FV guest using above kernel & virt tools

Steps to Reproduce:
1. Start virt-manager on rhel5 dom0
2. Select rhel4 fv guest
3. hit Run in console window for guest
4. hit mouse button in console window after guest running.

  
Actual results:
Dual mouse ptrs displayed;  have to enter CTL-ALT to get single, focused mouse ptr.

Expected results:
Single mouse ptr displayed after mouse click.

Additional info:
Comment 1 Daniel Berrange 2008-03-19 16:17:59 EDT
*** Bug 435786 has been marked as a duplicate of this bug. ***
Comment 2 Bill Burns 2008-03-20 09:03:25 EDT
Ser dev ack for Dan.
Comment 5 Daniel Berrange 2008-03-27 21:20:21 EDT
Fixed in gtk-vnc-0.3.2-3.el5
Comment 9 errata-xmlrpc 2008-05-21 11:37:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0370.html

Note You need to log in before you can comment on or make changes to this bug.