Bug 435786 - [RHEL 5.2]: virt-viewer does not always grab the focus when you click with the mouse
[RHEL 5.2]: virt-viewer does not always grab the focus when you click with th...
Status: CLOSED DUPLICATE of bug 433711
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-viewer (Show other bugs)
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Depends On:
  Show dependency treegraph
Reported: 2008-03-03 16:23 EST by Chris Lalancette
Modified: 2010-07-19 09:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-19 16:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2008-03-03 16:23:20 EST
Description of problem:
When first starting virt-viewer, it seems as if it will not grab the mouse
initially sometimes.  That is, I can type in the guest and otherwise interact
with it, but the mouse is not constrained.  If I hit "Ctrl-Alt" to force
virt-viewer to grab the focus, then hit "Ctrl-Alt" again to ungrab, then click
again, then virt-viewer will grab the focus.  This is with the RHEL-5.2 beta

Comment 1 RHEL Product and Program Management 2008-03-03 16:27:14 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 2 RHEL Product and Program Management 2008-03-11 15:35:41 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Chris Lalancette 2008-03-12 13:45:42 EDT
From a user perspective, this is a regression, even though virt-viewer is a new
component.  Marking it as such.

Chris Lalancette
Comment 4 RHEL Product and Program Management 2008-03-12 13:49:00 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 Daniel Berrange 2008-03-12 13:52:12 EDT
This is *not* a regression from a user perspective. Previously we used plain
'vncviewer' for console and it did no automatic mouse grab at all, so there's no
regression here. 

The behaviour where you press 'Alt+Ctrl' to trigger the grab is *intended*
behaviour for GTK-VNC. It will only automatically grab the cursor if the VNC
server supports the relative mouse pointer extension, which Xen does not.
Comment 6 Daniel Berrange 2008-03-19 16:17:58 EDT

*** This bug has been marked as a duplicate of 433711 ***
Comment 7 Chris Lalancette 2010-07-19 09:29:12 EDT
Clearing out old flags for reporting purposes.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.