Bug 43372 - Installer crashes when attempting to format partitions on hda.
Installer crashes when attempting to format partitions on hda.
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-04 09:31 EDT by Drone 247
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-06-19 11:27:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File jetisoned by anaconda as it is going down. (10.38 KB, text/plain)
2001-06-04 09:39 EDT, Drone 247
no flags Details

  None (edit)
Description Drone 247 2001-06-04 09:31:17 EDT
Description of Problem:
I have an Abit kt7a-raid board. I am trying to put RH7.1 on hda (w2k is on the hde / hdg raid setup). I get errors pertaining to hde and hdg before and after the partitioning section of the install. After partitioning hda (an 8.4 Gig samsung) I set the mount points. When the installation goes to format hda it crashes and burns, producing a debug report that I saved to disk. The debug report should be attached. I tried both graphical and non-graphical install, and encountered the same problem for each.

How Reproducible:
Every time.

Steps to Reproduce:
1. Abit kt7a-raid (maybe kt7-raid), seperate drive on ide0.
2. Try to install  RH7.1
3. partition hda and wait till you try to format it .... boom.

Actual Results:
Anaconda encounters a critical error and dumps some sort of log it told me to submit here.

Expected Results:
Format partitions correctly.

Additional Information:
To ensure that the iso image I burnt was not corrupt I tried to reproduce this bug on another machine. The install went fine, proving that the cd image is not corrupt.
Comment 1 Drone 247 2001-06-04 09:39:18 EDT
Created attachment 20201 [details]
File jetisoned by anaconda as it is going down.
Comment 2 Brent Fox 2001-06-04 11:31:57 EDT
Looks like you are having the exact same problem as bug #43321.  I think there
were some problems with the onboard RAID controller on this board.  Here's a
clip from an email on testers-list@redhat.com:

Just to follow up in this thread as well, I finally had a chance to test
again.  Following up in comments made in the "Crash on VIA chipsets"
thread, I went into the BIOS to change "K7 CLK_CTL Select" from the default
setting of "Optimal" to the other choice of "Default."
With this change, QA0319 now installs without any complaint or problem.
Looks like it was a BIOS issue.

Does changing the BIOS help you at all?
Comment 3 Drone 247 2001-06-08 09:05:43 EDT
I changed the CLK_CTL setting to from optimal to default as suggested. There was no change on my system - still crashed as reported.
Comment 4 Brent Fox 2001-06-14 12:00:42 EDT
If you look on VC3 and VC4, do you see any error messages?
Comment 5 Drone 247 2001-06-18 09:37:24 EDT
I should have thought of this b4, but disabling the onboard RAID when installing fixes the install problems (of course). After that the raid can be turned back on. Error messages are generated during power down, but no hangs or locks. It even works with CLK_CTRL set to optimal in the BIOS.

As for errors on VC3 and 4, yes. they are probably redundant now but ... these are the last few lines from a failed install ...

NOTE: These are for a graphical install with partitioning using fdisk.


*Swap attempt to 128M to 256M
*Autopartitioning failed because of the following errors:
*Failed to allocate '/boot': Boot partition > 1024 cylinders
*Failed to allocate '/': No free primary
*Failed to allocate '/Swap0000-auto': No free primary
*Maximum cylinder is 66


<4>ide2: reset: success
<4>hde: read_intr status=0x51 {DriveReady SeakComplete Error}
<4>hde: read_intr: error=0x10 {SectorIdNotFound}, LBAsect=44050232, sector=2
<4>end_request: I/O error, dev 21:03 (hde), sector 2

I don't need any more info as my install now works fine :-)

Many thanks!
Comment 6 Brent Fox 2001-06-19 11:27:35 EDT
Ok.  Glad to be of help.  Have fun.

Note You need to log in before you can comment on or make changes to this bug.