Bug 433971 - astyle failed massrebuild attempt for GCC 4.3
astyle failed massrebuild attempt for GCC 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: astyle (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
: 440797 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:51 EST by Jesse Keating
Modified: 2013-01-09 21:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 15:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gcc43 patch (247 bytes, patch)
2008-02-22 09:43 EST, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 07:51:18 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436021
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-22 09:24:22 EST
In file included from src/ASBeautifier.cpp:29:
src/astyle.h: In member function 'bool
astyle::ASFormatter::isSequenceReached(const char*) const':
src/astyle.h:488: error: 'strlen' was not declared in this scope
src/ASBeautifier.cpp: In member function 'virtual std::string
astyle::ASBeautifier::beautify(const std::string&)':
src/ASBeautifier.cpp:956: warning: suggest explicit braces to avoid ambiguous 'else'
src/ASBeautifier.cpp:1586: warning: suggest explicit braces to avoid ambiguous
'else'
In file included from src/ASEnhancer.cpp:36:
src/astyle.h: In member function 'bool
astyle::ASFormatter::isSequenceReached(const char*) const':
src/astyle.h:488: error: 'strlen' was not declared in this scope
src/ASEnhancer.cpp: In member function 'void
astyle::ASEnhancer::enhance(std::string&)':
src/ASEnhancer.cpp:214: warning: suggest explicit braces to avoid ambiguous 'else'
src/ASEnhancer.cpp:331: warning: suggest explicit braces to avoid ambiguous 'else'
src/ASEnhancer.cpp: In member function 'bool
astyle::ASEnhancer::findKeyword(const std::string&, int, const char*) const':
src/ASEnhancer.cpp:442: error: 'strlen' was not declared in this scope
In file included from src/ASFormatter.cpp:29:
src/astyle.h: In member function 'bool
astyle::ASFormatter::isSequenceReached(const char*) const':
src/astyle.h:488: error: 'strlen' was not declared in this scope
src/ASFormatter.cpp: In member function 'virtual std::string
astyle::ASFormatter::nextLine()':
src/ASFormatter.cpp:675: warning: suggest parentheses around && within ||
In file included from src/ASResource.cpp:29:
src/astyle.h: In member function 'bool
astyle::ASFormatter::isSequenceReached(const char*) const':
src/astyle.h:488: error: 'strlen' was not declared in this scope
In file included from src/astyle_main.cpp:29:
src/astyle.h: In member function 'bool
astyle::ASFormatter::isSequenceReached(const char*) const':
src/astyle.h:488: error: 'strlen' was not declared in this scope
src/astyle_main.cpp: In member function 'std::string
ASStreamIterator<T>::nextLine()':
src/astyle_main.cpp:190: error: there are no arguments to 'strcpy' that depend
on a template parameter, so a declaration of 'strcpy' must be available
src/astyle_main.cpp:190: error: (if you use '-fpermissive', G++ will accept your
code, but allowing the use of an undeclared name is deprecated)
src/astyle_main.cpp:192: error: there are no arguments to 'strcpy' that depend
on a template parameter, so a declaration of 'strcpy' must be available
src/astyle_main.cpp:195: error: there are no arguments to 'strcpy' that depend
on a template parameter, so a declaration of 'strcpy' must be available
src/astyle_main.cpp:197: error: there are no arguments to 'strcpy' that depend
on a template parameter, so a declaration of 'strcpy' must be available
src/astyle_main.cpp: In function 'bool isParamOption(const std::string&, const
char*)':
src/astyle_main.cpp:282: error: 'strlen' was not declared in this scope
src/astyle_main.cpp: In function 'bool parseOption(astyle::ASFormatter&, const
std::string&, const std::string&)':
src/astyle_main.cpp:379: error: 'strlen' was not declared in this scope
src/astyle_main.cpp:390: error: 'strlen' was not declared in this scope
src/astyle_main.cpp:405: error: 'strlen' was not declared in this scope
src/astyle_main.cpp:420: error: 'strlen' was not declared in this scope
src/astyle_main.cpp:431: error: 'strlen' was not declared in this scope
src/astyle_main.cpp:549: error: 'strlen' was not declared in this scope
src/astyle_main.cpp: In function 'int main(int, char**)':
src/astyle_main.cpp:956: error: 'strlen' was not declared in this scope
src/astyle_main.cpp: In member function 'std::string
ASStreamIterator<T>::nextLine() [with T = std::basic_istream<char,
std::char_traits<char> >]':
src/astyle_main.cpp:1135:   instantiated from here
src/astyle_main.cpp:190: error: 'strcpy' was not declared in this scope
src/astyle_main.cpp:192: error: 'strcpy' was not declared in this scope
src/astyle_main.cpp:195: error: 'strcpy' was not declared in this scope
src/astyle_main.cpp:197: error: 'strcpy' was not declared in this scope
Comment 2 Mamoru TASAKA 2008-02-22 09:43:07 EST
Created attachment 295633 [details]
gcc43 patch

This patch should be sufficient (it seems I am not in
ACL approved member)
Comment 3 Mamoru TASAKA 2008-02-22 09:45:00 EST
Also please change the license tag to "LGPLv2+".
Comment 4 Adam M. Dutko 2008-03-18 07:26:18 EDT
Patched, rebuilt on FC7.  Need to push to cvs and build through koji.  Link for
spec, srpm, and rpm is
http://littlehat.homelinux.org:8000/FEDORA/astyle/current/ .  Sorry for the delay.
Comment 5 Bug Zapper 2008-05-14 01:21:34 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Matt Domsch 2008-07-03 11:57:28 EDT
*** Bug 440797 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Kofler 2008-07-17 22:46:03 EDT
Ping? This patch has STILL not been applied! You MUST apply this patch as soon 
as possible, as all packages which fail to build from source will soon be 
REMOVED from Fedora!
Comment 8 FTBFS 2008-09-05 12:09:48 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 9 Mamoru TASAKA 2008-09-06 00:33:27 EDT
Adam, ping?
Comment 10 Adam M. Dutko 2008-09-09 10:57:39 EDT
I'm here.  I need to update the version because there was a new release.  I need to read up on how to do that before I submit an updated package.  ETA on that is most likely a few days.
Comment 11 Kevin Kofler 2008-09-17 19:16:22 EDT
1. cvs update
2. Download the new tarball into the astyle/devel directory.
3. make new-sources FILES=astyle... (use the name of the tarball you downloaded instead of "astyle...")
4. Edit the specfile, update Source0 to refer to the new tarball, bump Version, reset Release to 1%{?dist}, add a changelog entry.
5. Commit.
6. make tag
7. make build BUILD_FLAGS=--nowait
8. Wait for the build report Koji will mail you.

If the make new-sources, the commit or the build fails, you have to update your account security information:
* If you didn't reset your password through https://admin.fedoraproject.org/accounts/ yet since the infrastructure breach, you have to do it now.
* You have to reupload your SSH key through https://admin.fedoraproject.org/accounts/ if you didn't do that since the breach yet, or if it was a DSA one, generate a RSA one instead (ssh-keygen -t rsa) and upload that.
* You need new client certificates (for uploading and building) if you didn't update them since the breach already, see:
https://www.redhat.com/archives/fedora-devel-announce/2008-August/msg00008.html
Comment 12 Debarshi Ray 2008-09-23 13:49:55 EDT
I am re-assigning this bug to myself since I own this package now.
Comment 13 Fedora Update System 2008-09-23 15:19:41 EDT
astyle-1.21-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/astyle-1.21-9.fc9
Comment 14 Fedora Update System 2008-10-15 22:13:19 EDT
astyle-1.21-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.