Bug 433980 - multiget failed massrebuild attempt for GCC 4.3
multiget failed massrebuild attempt for GCC 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: multiget (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Guido Ledermann
Fedora Extras Quality Assurance
:
: 440801 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:52 EST by Jesse Keating
Modified: 2013-01-09 21:47 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2.0-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-04 05:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 07:52:15 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436126
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-22 13:20:26 EST
mgurlparser.cpp: In member function '_PROTYPE CUrlParser::UrlType(std::string)':
mgurlparser.cpp:277: error: 'strncasecmp' was not declared in this scope
mgurlparser.cpp:280: error: 'strncasecmp' was not declared in this scope
mgurlparser.cpp: In member function 'bool CUrlParser::GetUserAndPass(const
std::string&, std::string&, std::string&)':
mgurlparser.cpp:315: error: 'strcpy' was not declared in this scope
mgurlparser.cpp:320: error: 'strlen' was not declared in this scope
mgurlparser.cpp:377: error: 'memcpy' was not declared in this scope
mgurlparser.cpp: In member function 'bool CUrlParser::GetServerAndPort(const
std::string&, std::string&, int&)':
mgurlparser.cpp:415: error: 'strcpy' was not declared in this scope
mgurlparser.cpp:420: error: 'strlen' was not declared in this scope
mgurlparser.cpp:468: error: 'memcpy' was not declared in this scope
mgurlparser.cpp:491: error: 'memcpy' was not declared in this scope
mgurlparser.cpp:513: error: 'atoi' was not declared in this scope
mgurlparser.cpp:560: error: 'memcpy' was not declared in this scope
mgurlparser.cpp:583: error: 'memcpy' was not declared in this scope
mgurlparser.cpp:605: error: 'atoi' was not declared in this scope
mgurlparser.cpp: In member function 'bool CUrlParser::GetRawUrl(std::string&,
std::string&)':
mgurlparser.cpp:643: error: 'strcpy' was not declared in this scope
mgurlparser.cpp:666: error: 'strlen' was not declared in this scope
mgurlparser.cpp:695: error: 'memcpy' was not declared in this scope
mgurlparser.cpp: In member function 'bool CUrlParser::GetPathFile(std::string&,
std::string&)':
mgurlparser.cpp:711: error: 'strcpy' was not declared in this scope
mgurlparser.cpp:737: error: 'strlen' was not declared in this scope
mgurlparser.cpp:743: error: 'strlen' was not declared in this scope
mgurlparser.cpp:743: error: 'memcpy' was not declared in this scope
mgurlparser.cpp: In member function 'bool CUrlParser::GetRefer(std::string,
std::string&)':
mgurlparser.cpp:760: error: 'strcpy' was not declared in this scope
mgurlparser.cpp:762: error: 'strlen' was not declared in this scope
mgurlparser.cpp:778: error: 'memcpy' was not declared in this scope
mgurlparser.cpp: In member function 'void CUrlParser::Precode(const
std::string&, std::string&)':
mgurlparser.cpp:839: error: 'strncpy' was not declared in this scope
mgurlparser.cpp:845: error: 'strncpy' was not declared in this scope
mgurlparser.cpp: In member function 'void CUrlParser::UnEscape(std::string&)':
mgurlparser.cpp:916: error: 'strcpy' was not declared in this scope
Comment 2 Bug Zapper 2008-05-14 01:21:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 12:22:04 EDT
*** Bug 440801 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Wickert 2008-07-04 05:08:00 EDT
Patch for GCC 4.3 is included in multiget-1.2.0-3.fc{8|9}, see
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-6036 and
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6056

Reassigning to the new owner and closing.

Note You need to log in before you can comment on or make changes to this bug.