Bug 434004 - ghc failed massrebuild attempt for GCC 4.3
ghc failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan O'Sullivan
Fedora Extras Quality Assurance
:
: 440948 449664 (view as bug list)
Depends On:
Blocks: FTBFS gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 07:54 EST by Jesse Keating
Modified: 2013-01-09 21:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 21:58:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 07:54:40 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=436847
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-23 14:17:18 EST
Socket.hsc: In function 'main':
Socket.hsc:1144: error: invalid application of 'sizeof' to incomplete type
'struct ucred' 
Socket.hsc:1144: error: invalid application of 'sizeof' to incomplete type
'struct ucred' 
Socket.hsc:1144: error: invalid application of 'sizeof' to incomplete type
'struct ucred' 
Socket.hsc:1150: error: invalid use of undefined type 'struct ucred'
Socket.hsc:1151: error: invalid use of undefined type 'struct ucred'
Socket.hsc:1152: error: invalid use of undefined type 'struct ucred'
Comment 2 Bug Zapper 2008-05-14 01:22:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bryan O'Sullivan 2008-05-28 16:28:57 EDT
*** Bug 440948 has been marked as a duplicate of this bug. ***
Comment 4 Bryan O'Sullivan 2008-05-28 16:30:19 EDT
Reported upstream as http://hackage.haskell.org/trac/ghc/ticket/2314

I've attached a patch to the upstream bug.  I'll fix this in a week or two, when
GHC 6.8.3 is released.
Comment 5 Bryan O'Sullivan 2008-06-02 19:30:24 EDT
*** Bug 449664 has been marked as a duplicate of this bug. ***
Comment 6 Jens Petersen 2008-06-13 00:20:57 EDT
Bryan told me he has a fix for this.
Comment 7 Jens Petersen 2008-06-22 19:30:36 EDT
Bryan built ghc-6.8.3 in devel.

Note You need to log in before you can comment on or make changes to this bug.