Bug 434061 - gpsim failed massrebuild attempt for GCC 4.3
Summary: gpsim failed massrebuild attempt for GCC 4.3
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gpsim
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alain Portal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 440835 (view as bug list)
Depends On:
Blocks: gcc43errors
TreeView+ depends on / blocked
 
Reported: 2008-02-22 13:00 UTC by Jesse Keating
Modified: 2013-01-10 02:51 UTC (History)
4 users (show)

Fixed In Version: 0.22.0-7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-07 19:39:23 UTC
Type: ---


Attachments (Terms of Use)
This patch works for me on F9. (7.18 KB, patch)
2008-09-06 16:50 UTC, Vasile Gaburici
no flags Details | Diff

Description Jesse Keating 2008-02-22 13:00:52 UTC
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438244
Exit code was 1, check the build.log for the failed buildArch task.

Comment 1 Tyler Owen 2008-02-24 02:50:55 UTC
Errors in i386 build.log:

In file included from ../src/registers.h:34,
                 from ../src/ui.h:11,
                 from ../src/cmd_gpsim.h:5,
                 from misc.h:24,
                 from parse.yy:33:
../src/value.h: In function 'bool operator!=(String&, String&)':
../src/value.h:590: error: 'strcmp' was not declared in this scope
In file included from ../src/registers.h:34,
                 from ../src/ui.h:11,
                 from ../src/cmd_gpsim.h:5,
                 from misc.h:24,
                 from command.h:28,
                 from scan.ll:35:
../src/value.h: In function 'bool operator!=(String&, String&)':
../src/value.h:590: error: 'strcmp' was not declared in this scope
parse.cc: In function 'int yyparse()':
parse.cc:2802: warning: deprecated conversion from string constant to 'char*'
parse.cc:2806: warning: deprecated conversion from string constant to 'char*'
parse.cc:2927: warning: deprecated conversion from string constant to 'char*'
In file included from ../src/processor.h:30,
                 from scan.ll:45:
../src/modules.h: In constructor 'ModuleLibrary::File::File(const char*, void*)':
../src/modules.h:155: error: 'strdup' was not declared in this scope
make[2]: *** [parse.lo] Error 1

Comment 2 Bug Zapper 2008-05-14 05:23:41 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Matt Domsch 2008-07-03 16:09:20 UTC
*** Bug 440835 has been marked as a duplicate of this bug. ***

Comment 4 FTBFS 2008-09-05 16:11:37 UTC
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.

Comment 5 Vasile Gaburici 2008-09-06 16:50:45 UTC
Created attachment 315954 [details]
This patch works for me on F9.

Comment 6 Kevin Kofler 2008-09-07 19:39:23 UTC
I applied this patch, except for the list->listme rename where I used Debian's simpler fix instead (explicitly qualifying std::list).

Comment 7 Kevin Kofler 2008-09-07 20:00:40 UTC
Also applied Mamoru Tasaka's PPC fix, now it actually builds on all arches.

Comment 8 Alain Portal 2008-09-08 07:34:11 UTC
Thank for the fix and the built


Note You need to log in before you can comment on or make changes to this bug.