This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 434070 - mtd-utils failed massrebuild attempt for GCC 4.3
mtd-utils failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtd-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
: 440845 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:01 EST by Jesse Keating
Modified: 2013-01-09 21:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 08:01:45 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438426
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-23 21:55:30 EST
errors in x86_64 build.log:


gcc -I./include -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -g -c -o
recv_image.o recv_image.c -g -Wp,-MD,./.recv_image.c.dep
recv_image.c: In function 'main':
recv_image.c:128: error: storage size of 'rq' isn't known
recv_image.c:128: warning: unused variable 'rq'
recv_image.c:169: warning: format '%d' expects type 'int', but argument 3 has
type 'size_t'
recv_image.c:169: warning: format '%d' expects type 'int', but argument 4 has
type 'long unsigned int'
recv_image.c:310: warning: format '%08lx' expects type 'long unsigned int', but
argument 2 has type 'uint32_t'
recv_image.c:310: warning: format '%08lx' expects type 'long unsigned int', but
argument 3 has type 'uint32_t'
recv_image.c:310: warning: format '%08lx' expects type 'long unsigned int', but
argument 4 has type 'uint32_t'
make: *** [recv_image.o] Error 1
Comment 2 Bug Zapper 2008-05-14 01:24:20 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 11:58:08 EDT
*** Bug 440845 has been marked as a duplicate of this bug. ***
Comment 4 Matt Domsch 2008-07-08 00:38:22 EDT
builds as of 2008-07-03, version 1.2.0-1.fc10.

Note You need to log in before you can comment on or make changes to this bug.