Bug 434071 - petitboot failed massrebuild attempt for GCC 4.3
petitboot failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: petitboot (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
: 440853 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 08:01 EST by Jesse Keating
Modified: 2013-01-09 21:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 14:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 08:01:51 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=438441
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-23 21:54:15 EST
Errors in i386 build.log:

gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -I. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -I.   -c -o devices/yaboot-parser.o
devices/yaboot-parser.c
devices/udev-helper.c: In function 'is_removable_device':
devices/udev-helper.c:321: error: 'PATH_MAX' undeclared (first use in this function)
devices/udev-helper.c:321: error: (Each undeclared identifier is reported only once
devices/udev-helper.c:321: error: for each function it appears in.)
devices/udev-helper.c:321: warning: unused variable 'full_path'
devices/udev-helper.c: In function 'found_new_device':
devices/udev-helper.c:352: error: 'PATH_MAX' undeclared (first use in this function)
devices/udev-helper.c:352: warning: unused variable 'mountpoint'
petitboot.c: In function 'pboot_event_filter':
petitboot.c:795: warning: ignoring return value of 'system', declared with
attribute warn_unused_result
devices/udev-helper.c: In function 'poll_device_plug':
devices/udev-helper.c:402: error: 'INT_MAX' undeclared (first use in this function)
devices/udev-helper.c: In function 'poll_device_unplug':
devices/udev-helper.c:440: error: 'INT_MAX' undeclared (first use in this function)
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -I. -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -I.   -c -o devices/kboot-parser.o
devices/kboot-parser.c
make: *** [devices/udev-helper.o] Error 1
make: *** Waiting for unfinished jobs....
devices/kboot-parser.c: In function 'parse_option':
devices/kboot-parser.c:132: warning: ignoring return value of 'asprintf',
declared with attribute warn_unused_result
devices/kboot-parser.c:140: warning: ignoring return value of 'asprintf',
declared with attribute warn_unused_result
devices/kboot-parser.c:146: warning: ignoring return value of 'asprintf',
declared with attribute warn_unused_result
devices/kboot-parser.c:154: warning: ignoring return value of 'asprintf',
declared with attribute warn_unused_result
error: Bad exit status from /var/tmp/rpm-tmp.6090 (%build)
Comment 2 Bug Zapper 2008-05-14 01:24:28 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 11:34:01 EDT
*** Bug 440853 has been marked as a duplicate of this bug. ***
Comment 4 FTBFS 2008-09-05 12:25:18 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 5 David Woodhouse 2008-09-05 12:37:00 EDT
%changelog
* Fri Apr 18 2008 David Woodhouse <dwmw2@infradead.org> - 2.5.0-7
- Fix GCC 4.3 compilation (#440981)
Comment 6 David Woodhouse 2008-09-05 12:37:44 EDT
oops, wrong bug; sorry. I'll go look at petitboot now.
Comment 7 Matt Domsch 2008-09-18 14:16:30 EDT
Build fix: include <linux/limits.h> in devices/udev-helper.c.
Built in rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=832350
Comment 8 David Woodhouse 2008-09-18 15:21:11 EDT
I don't like the fix. Why are we using kernel headers instead of glibc headers?
That's almost always the wrong thing to do.

Note You need to log in before you can comment on or make changes to this bug.