Bug 434217 - fityk failed massrebuild attempt for GCC 4.3
fityk failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fityk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Pye
Fedora Extras Quality Assurance
: Reopened
: 440884 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 10:49 EST by Jesse Keating
Modified: 2013-01-09 22:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 22:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing #includes (1.02 KB, patch)
2008-04-06 14:18 EDT, Christopher Aillon
no flags Details | Diff

  None (edit)
Description Jesse Keating 2008-02-22 10:49:16 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=440426
Unknown exit code, check the failed task.
Comment 1 Tyler Owen 2008-02-26 06:58:57 EST
Koji Error
exceptions.OSError: [Errno 31] Too many links: '/mnt/koji/work/tasks/445422'
          
Comment 2 Jesse Keating 2008-02-28 09:55:44 EST
Resubmitted as 475448
Comment 3 Jesse Keating 2008-02-28 10:21:56 EST
Oops, jumped the gun.

 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../3rdparty -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
libfityk_la-ui.lo -MD -MP -MF .deps/libfityk_la-ui.Tpo -c ui.cpp  -fPIC -DPIC -o
.libs/libfityk_la-ui.o
ui.cpp: In function 'bool is_fityk_script(std::string)':
ui.cpp:259: error: 'strlen' was not declared in this scope
ui.cpp:262: error: 'strncmp' was not declared in this scope
make[3]: *** [libfityk_la-ui.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/builddir/build/BUILD/fityk-0.8.1/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/fityk-0.8.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/fityk-0.8.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.11229 (%build)
Comment 4 Christopher Aillon 2008-04-06 14:18:43 EDT
Created attachment 301433 [details]
Missing #includes
Comment 5 Christopher Aillon 2008-04-06 14:55:57 EDT
I attempted to build this in koji but couldn't...

**** Access denied: caillon is not in ACL for rpms/fityk/devel
Comment 6 John Pye 2008-04-06 23:19:50 EDT
FWIW Fityk 0.8.5 is now available; we should be updating to a new package rather
than patching the old one?

I don't currently have my Fedora machine connected to the next, so I'm not
easily able to help with this right now.
Comment 7 Jesse Keating 2008-04-07 22:44:43 EDT
Submitted as http://koji.fedoraproject.org/koji/taskinfo?taskID=555853
Comment 8 Matt Domsch 2008-07-03 13:38:53 EDT
*** Bug 440884 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.