Bug 434300 - gnome-applet-tvn24 failed massrebuild attempt for GCC 4.3
gnome-applet-tvn24 failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applet-tvn24 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub 'Livio' Rusinek
Fedora Extras Quality Assurance
:
: 440715 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 10:57 EST by Jesse Keating
Modified: 2013-01-09 22:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 09:52:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 10:57:03 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=441769
Exit code was 30, check the root.log for the failed buildArch task.
Comment 1 Jakub 'Livio' Rusinek 2008-02-22 13:05:35 EST
Not sure if I should close it or which resolution should I pick...

I can't fix it now, because libxml2-devel has g-a-t's dependency file removed
(tree.h), so author of applet needs to update package.

I can do nothing.
Comment 2 Jakub 'Livio' Rusinek 2008-02-22 13:11:26 EST
I've got something strange in root.log

> DEBUG util.py:261:  Error: Missing Dependency: libcap.so.1()(64bit) is needed
by package dbus
> DEBUG util.py:261:  Error: Missing Dependency: libcap.so.1()(64bit) is needed
by package avahi
> DEBUG util.py:261:  Error: Missing Dependency: libcap.so.1()(64bit) is needed
by package dbus-libs
Comment 3 Jesse Keating 2008-02-22 17:37:46 EST
Resubmitted as 462465, the broken deps should be fixed.
Comment 4 Jesse Keating 2008-02-22 20:39:10 EST
The attempted rebuild failed with a build error.

http://koji.fedoraproject.org/koji/getfile?taskID=462468&name=build.log

gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\"
-DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"PasekTVN24\"
-DVERSION=\"0.2.8\" -I. `/usr/bin/pkg-config --cflags libpanelapplet-2.0
gdk-pixbuf-xlib-2.0 gnome-vfs-2.0`    -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT
tvn24.o -MD -MP -MF .deps/tvn24.Tpo -c -o tvn24.o tvn24.c
tvn24.c:36:27: error: libxml/parser.h: No such file or directory
tvn24.c:37:25: error: libxml/tree.h: No such file or directory
In file included from tvn24.c:39:
tvn24.h:202: error: expected declaration specifiers or '...' before 'xmlNode'
tvn24.h:203: error: expected ')' before '*' token
tvn24.c:1794: error: expected declaration specifiers or '...' before 'xmlNode'
tvn24.c: In function 'get_attribute_value':
tvn24.c:1796: error: 'xmlNode' undeclared (first use in this function)
tvn24.c:1796: error: (Each undeclared identifier is reported only once
tvn24.c:1796: error: for each function it appears in.)
tvn24.c:1796: error: 'cur_node' undeclared (first use in this function)
tvn24.c:1798: error: 'node' undeclared (first use in this function)
tvn24.c:1798: error: 'XML_ATTRIBUTE_NODE' undeclared (first use in this function)
tvn24.c:1798: warning: implicit declaration of function 'strcmp'
tvn24.c: At top level:
tvn24.c:1804: error: expected ')' before '*' token
tvn24.c: In function 'xml_reader':
tvn24.c:1875: error: 'xmlDocPtr' undeclared (first use in this function)
tvn24.c:1875: error: expected ';' before 'doc'
tvn24.c:1876: error: 'xmlNode' undeclared (first use in this function)
tvn24.c:1876: error: 'element' undeclared (first use in this function)
tvn24.c:1906: error: 'doc' undeclared (first use in this function)
tvn24.c:1906: warning: implicit declaration of function 'xmlReadMemory'
tvn24.c:1906: error: 'XML_PARSE_NOERROR' undeclared (first use in this function)
tvn24.c:1906: error: 'XML_PARSE_NONET' undeclared (first use in this function)
tvn24.c:1910: warning: implicit declaration of function 'xmlDocGetRootElement'
tvn24.c:1913: warning: implicit declaration of function 'analyse_xml'
tvn24.c:1927: warning: implicit declaration of function 'xmlFreeDoc'
tvn24.c:1878: warning: unused variable 'i'
tvn24.c: In function 'panel_main':
tvn24.c:2205: warning: unused variable 'rgba'
tvn24.c:2204: warning: unused variable 'screen'
make: *** [tvn24.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.95464 (%build)

Comment 5 Jakub 'Livio' Rusinek 2008-02-29 00:41:01 EST
> tvn24.c:36:27: error: libxml/parser.h: No such file or directory
> tvn24.c:37:25: error: libxml/tree.h: No such file or directory

newest libxml2-devel doesn't provide them.

I knew about this.

I cannot fix this bug, until author of this applet releases new version.
Comment 6 Bug Zapper 2008-05-14 01:28:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matt Domsch 2008-07-03 11:49:36 EDT
*** Bug 440715 has been marked as a duplicate of this bug. ***
Comment 8 Matt Domsch 2008-09-05 09:52:38 EDT
builds 2008-08-24

Note You need to log in before you can comment on or make changes to this bug.