Bug 434376 - mono-debugger failed massrebuild attempt for GCC 4.3
mono-debugger failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mono-debugger (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
: 440938 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:06 EST by Jesse Keating
Modified: 2013-01-09 22:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 00:38:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:06:23 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=443250
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-02-29 21:42:02 EST
scratch build 480738
Comment 2 Jon Stanley 2008-02-29 22:03:29 EST
In file included from x86-ptrace.c:539:
i386-arch.c: At top level:
i386-arch.c:27: error: field 'current_regs' has incomplete type
i386-arch.c:28: error: field 'current_fpregs' has incomplete type
i386-arch.c:37: error: field 'saved_regs' has incomplete type
i386-arch.c:38: error: field 'saved_fpregs' has incomplete type
Comment 3 Sandro Bonazzola 2008-03-18 16:09:35 EDT
See similar issue in Gentoo Bugzilla: http://bugs.gentoo.org/show_bug.cgi?id=193699
Maybe a joint collaboration for solving this bug could help both distributions.
Comment 4 Paul F. Johnson 2008-05-11 16:56:58 EDT
This is a kernel problem. I'm waiting for an upstream fix. mono-debugger 0.90
should be due out any time soon...
Comment 5 Bug Zapper 2008-05-14 01:31:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Matt Domsch 2008-07-03 12:10:36 EDT
*** Bug 440938 has been marked as a duplicate of this bug. ***
Comment 7 Matt Domsch 2008-07-08 00:38:15 EDT
builds as of 2008-07-03, version 0.60-3.fc10.

Note You need to log in before you can comment on or make changes to this bug.