Bug 434382 - blam failed massrebuild attempt for GCC 4.3
blam failed massrebuild attempt for GCC 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
: 449619 (view as bug list)
Depends On: 439931
Blocks: gcc43rebuildfail F9Upgrade
  Show dependency treegraph
 
Reported: 2008-02-22 11:07 EST by Jesse Keating
Modified: 2013-01-09 22:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.8.5-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:07:02 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=443354
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Tyler Owen 2008-02-23 21:29:53 EST
Configure failure for PPC:

checking which mozilla to use... configure: error: no mozilla installation found
error: Bad exit status from /var/tmp/rpm-tmp.14312 (%build)
Comment 2 Alex Lancaster 2008-04-07 09:27:50 EDT
This is not a problem with gcc 4.3 per se, it's a problem with port to using
xulrunner rather than firefox-devel.  This was fixed at some point, and is now
unfixed (will check for old bug).
Comment 3 Alex Lancaster 2008-04-11 07:49:46 EDT
Can't update to latest blam which may fix the xulrunner problem because
gnome-sharp  is too low.
Comment 4 Bug Zapper 2008-05-14 01:31:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matt Domsch 2008-07-03 13:19:57 EDT
*** Bug 449619 has been marked as a duplicate of this bug. ***
Comment 6 Alex Lancaster 2008-07-19 20:04:06 EDT
Still a problem in rawhide, switching components.  Trying some new builds now
(broken deps in F-9 too).
Comment 7 Alex Lancaster 2008-07-19 21:31:00 EDT
OK, so the xulrunner check doesn't seem to be working correctly:

http://koji.fedoraproject.org/koji/taskinfo?taskID=728077

http://koji.fedoraproject.org/koji/getfile?taskID=728079&name=build.log

/configure: line 22066: test: too many arguments
xulrunner
checking for MOZILLA_COMPONENT... 
configure: error: Package requirements (xulrunner-gtkmozembed >= 1.8
xulrunner-xpcom >= 1.8) were not met:
No package 'xulrunner-gtkmozembed' found
No package 'xulrunner-xpcom' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables MOZILLA_COMPONENT_CFLAGS
and MOZILLA_COMPONENT_LIBS to avoid the need to call pkg-config.


So the current xulrunner patch doesn't appear to be sufficient.  I think the
xulrunner-devel library is called something different in the Fedora library,
libxul-xpcom or somesuch.  An expert on gecko/xulrunner might know what exactly
is needed here.
Comment 8 Fedora Update System 2008-07-21 10:22:22 EDT
blam-1.8.5-1.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-07-23 03:06:04 EDT
blam-1.8.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-07-26 02:01:50 EDT
blam-1.8.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.