Bug 434445 - supertux failed massrebuild attempt for GCC 4.3
supertux failed massrebuild attempt for GCC 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: supertux (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
: 440816 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:25 EST by Jesse Keating
Modified: 2013-01-09 22:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 05:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:25:09 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=445807
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Henning Norén 2008-02-22 17:59:26 EST
C++ ./build/x86_64-redhat-linux-gnu/optimize/src/scripting/time_scheduler.o 
In file included from ./src/log.hpp:26,
                 from ./src/video/color.hpp:25,
                 from ./src/sprite/sprite.hpp:29,
                 from ./src/object/moving_sprite.hpp:25,
                 from ./src/object/candle.hpp:26,
                 from src/scripting/candle.cpp:24:
./src/console.hpp:93: error: ISO C++ forbids declaration of 'auto_ptr' with no type
./src/console.hpp:93: error: invalid use of '::'
./src/console.hpp:93: error: expected ';' before '<' token
./src/console.hpp:94: error: ISO C++ forbids declaration of 'auto_ptr' with no type
./src/console.hpp:94: error: invalid use of '::'
./src/console.hpp:94: error: expected ';' before '<' token
./src/console.hpp:104: error: ISO C++ forbids declaration of 'auto_ptr' with no type
./src/console.hpp:104: error: invalid use of '::'
./src/console.hpp:104: error: expected ';' before '<' token
C++ ./build/x86_64-redhat-linux-gnu/optimize/src/scripting/level_time.o 
C++ ./build/x86_64-redhat-linux-gnu/optimize/src/scripting/wrapper.o 

    g++ -c -o ./build/x86_64-redhat-linux-gnu/optimize/src/scripting/candle.o 
-I. -I./src -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT  -pthread 
-I/usr/include -I/usr/include   -Isrc/squirrel/include -Isrc/squirrel -O2 -g
-pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -Wall -O3 -g
-DAPPDATADIR='"/usr/share/supertux"' src/scripting/candle.cpp

...failed C++ ./build/x86_64-redhat-linux-gnu/optimize/src/scripting/candle.o ...
XGetText data/locale/messages.pot 
...skipped supertux for lack of <T!src!>spawn_point.o...
...failed updating 104 target(s)...
...skipped 1 target(s)...
...updated 130 target(s)...
error: Bad exit status from /var/tmp/rpm-tmp.32906 (%build)
Comment 2 Bug Zapper 2008-05-14 01:33:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matt Domsch 2008-07-03 13:08:25 EDT
*** Bug 440816 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Goede 2008-07-10 05:01:23 EDT
I'm currently doing a local build with a patch fixing this, as soon as its
tested I'll commit to CVS and build it (if the ACL allows me to, otherwise I'll
attach the patch here).
Comment 5 Hans de Goede 2008-07-10 05:34:49 EDT
Fixed in rawhide new, closing.

Note You need to log in before you can comment on or make changes to this bug.