Bug 434458 - python-tag failed massrebuild attempt for GCC 4.3
python-tag failed massrebuild attempt for GCC 4.3
Status: CLOSED DUPLICATE of bug 440759
Product: Fedora
Classification: Fedora
Component: python-tag (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:26 EST by Jesse Keating
Modified: 2013-01-09 22:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-20 11:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:26:35 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=446383
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-03-04 23:45:15 EST
scratch build 493000
Comment 2 Jon Stanley 2008-03-05 00:02:07 EST
/usr/include/boost/python/detail/invoke.hpp: In function 'PyObject*
boost::python::detail::invoke(boost::python::detail::invoke_tag_<false, true>,
const RC&, F&, TC&) [with RC = boost::python::detail::caller_arity<1u>::impl<F,
Policies, Sig>::operator()(PyObject*, PyObject*) [with F =
TagLib::List<TagLib::StringList*>& (TagLib::List<TagLib::StringList*>::*)(),
Policies = boost::python::default_call_policies, Sig =
boost::mpl::vector2<TagLib::List<TagLib::StringList*>&,
TagLib::List<TagLib::StringList*>&>]::result_converter, F =
TagLib::List<TagLib::StringList*>& (TagLib::List<TagLib::StringList*>::*)(), TC
= boost::python::detail::caller_arity<1u>::impl<F, Policies,
Sig>::operator()(PyObject*, PyObject*) [with F =
TagLib::List<TagLib::StringList*>& (TagLib::List<TagLib::StringList*>::*)(),
Policies = boost::python::default_call_policies, Sig =
boost::mpl::vector2<TagLib::List<TagLib::StringList*>&,
TagLib::List<TagLib::StringList*>&>]::c_t0]':
/usr/include/boost/python/detail/caller.hpp:199:   instantiated from 'PyObject*
boost::python::detail::caller_arity<1u>::impl<F, Policies,
Sig>::operator()(PyObject*, PyObject*) [with F =
TagLib::List<TagLib::StringList*>& (TagLib::List<TagLib::StringList*>::*)(),
Policies = boost::python::default_call_policies, Sig =
boost::mpl::vector2<TagLib::List<TagLib::StringList*>&,
TagLib::List<TagLib::StringList*>&>]'
/usr/include/boost/python/object/py_function.hpp:38:   instantiated from
'PyObject*
boost::python::objects::caller_py_function_impl<Caller>::operator()(PyObject*,
PyObject*) [with Caller =
boost::python::detail::caller<TagLib::List<TagLib::StringList*>&
(TagLib::List<TagLib::StringList*>::*)(), boost::python::default_call_policies,
boost::mpl::vector2<TagLib::List<TagLib::StringList*>&,
TagLib::List<TagLib::StringList*>&> >]'
src/basics.cpp:203:   instantiated from here
/usr/include/boost/python/detail/invoke.hpp:88: error: no match for call to
'(const
boost::python::detail::specify_a_return_value_policy_to_wrap_functions_returning<TagLib::List<TagLib::StringList*>&>)
(TagLib::List<TagLib::StringList*>&)'
error: command 'gcc' failed with exit status 1
Comment 3 Bill Nottingham 2008-04-20 11:19:44 EDT
This has nothing to do with gcc-4.3; it's a package bug with respect to the
newer taglib.

*** This bug has been marked as a duplicate of 440759 ***

Note You need to log in before you can comment on or make changes to this bug.