Bug 434519 - dar failed massrebuild attempt for GCC 4.3
dar failed massrebuild attempt for GCC 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dar (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
: 440746 (view as bug list)
Depends On:
Blocks: gcc43errors
  Show dependency treegraph
 
Reported: 2008-02-22 11:32 EST by Jesse Keating
Modified: 2013-01-09 22:17 EST (History)
4 users (show)

See Also:
Fixed In Version: dar-2.3.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 18:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-02-22 11:32:44 EST
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=447861
Exit code was 1, check the build.log for the failed buildArch task.
Comment 1 Jon Stanley 2008-03-05 18:28:15 EST
scratch build 495598
Comment 2 Jon Stanley 2008-03-05 18:36:47 EST
storage.hpp: In member function 'void libdar::storage::iterator::skip_less_one()':
storage.hpp:217: warning: suggest explicit braces to avoid ambiguous 'else'
erreurs.cpp: In function 'void libdar::inattendue()':
erreurs.cpp:125: error: 'exit' was not declared in this scope
erreurs.cpp: In function 'void libdar::notcatched()':
erreurs.cpp:138: error: 'exit' was not declared in this scope
Comment 3 Bug Zapper 2008-05-14 01:33:52 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Domsch 2008-07-03 11:53:27 EDT
*** Bug 440746 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Garski 2008-08-04 13:43:29 EDT
Updated to 2.3.8 which fix GCC 4.3 compile errors. New version should appear soon as update.
Comment 6 Fedora Update System 2008-08-04 14:01:17 EDT
dar-2.3.8-1.fc9 has been submitted as an update for Fedora 9
Comment 7 Fedora Update System 2008-08-07 19:53:53 EDT
dar-2.3.8-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dar'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7063
Comment 8 Fedora Update System 2008-08-12 14:20:35 EDT
dar-2.3.8-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.