Bug 434574 - Incompatibility between Scalar::Util and Compress::Zlib modules
Incompatibility between Scalar::Util and Compress::Zlib modules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Compress-Zlib (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 434617 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-22 16:14 EST by Dan Stahlke
Modified: 2008-07-04 23:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.8.8-36.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 14:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Stahlke 2008-02-22 16:14:55 EST
Description of problem:
There is an incompatibility between Scalar::Util and Compress::Zlib modules. 
Compress::Zlib seems to need Scalar::Util to be compiled with XS.

Version-Release number of selected component (if applicable):
perl v5.8.8

How reproducible:
perl -MCompress::Zlib -e 0

Steps to Reproduce:
1. perl -MCompress::Zlib -e 0
2.
3.
  
Actual results:
 is only avaliable with the XS version at
/usr/lib/perl5/vendor_perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require.
BEGIN failed--compilation aborted.


Expected results:
No error

Additional info:
Originally I had my own modules from CPAN, but I removed everything from
site-perl and installed Compress::Zlib via yum.  The error is still there.
Comment 1 Dan Stahlke 2008-02-22 16:30:28 EST
It appears that several other modules also have issue with Scalar::Util::dualvar
not being available.
Comment 2 Dan Stahlke 2008-02-23 17:04:03 EST
This same bug has been reported in CentOS 3:
http://bugs.centos.org/view.php?id=2434

Related discussion:
http://www.perlmonks.org/?node_id=460411

The fix:
  perl -MCPAN -e shell
  force install Scalar::Util
Comment 3 Gianluca Varisco 2008-02-24 08:42:37 EST
*** Bug 434617 has been marked as a duplicate of this bug. ***
Comment 4 Dan Stahlke 2008-02-24 16:01:38 EST
This bug has been tagged as a perl-Compress-Zlib bug but I think the root issue
is with Scalar::Util which is part of the core perl modules.  The issue is that
the Scalar::Util::dualvar function is not available because the module has not
been compiled with XS.  The manpage for that module does not say that dualvar is
only sometimes available which leads me to believe that the function is not
supposed to disappear.  Other modules besides Compress::Zlib also need dualvar.
Comment 5 Tom "spot" Callaway 2008-02-25 22:48:17 EST
Except that I'm pretty darned sure that the Scalar::Util shipped in Fedora is
compiled with XS.

[spot@localhost ~]$ perl -e 'use Scalar::Util "dualvar"'
[spot@localhost ~]$ rpm -q perl
perl-5.8.8-31.fc9.x86_64

Something else strange is happening, the only time this "bug" ever comes out is
when people start using modules from CPAN. Best guess? Something is overriding it.
Comment 6 Marcela Mašláňová 2008-02-26 07:40:20 EST
In CPAN is newer version with this part added.

diff Scalar-List-Utils-1.18/Makefile.PL Scalar-List-Utils-1.19/Makefile.PL
36a37,42
>   return <<'POST_CONST' if $^O eq 'MSWin32';
>
> XSUBPPARGS = $(XSUBPPARGS) -typemap mytypemap
>
> POST_CONST
>

mytypemap could be used only for perl < 5.6.1 (wrote in mytypemap file). Could
be bug in Scalar::Utils module?
Comment 7 Jan Pazdziora 2008-02-28 09:10:16 EST
(In reply to comment #6)
> In CPAN is newer version with this part added.
> 
> diff Scalar-List-Utils-1.18/Makefile.PL Scalar-List-Utils-1.19/Makefile.PL
> 36a37,42
> >   return <<'POST_CONST' if $^O eq 'MSWin32';

But this only concerns MS Windows.

Anyway, as per spot's comment, the dualvar seems to be there in Scalar::Util
distributed in perl rpm in Fedora 8.
Comment 8 Fedora Update System 2008-02-29 10:25:50 EST
perl-5.8.8-35.fc8 has been submitted as an update for Fedora 8
Comment 9 Marcela Mašláňová 2008-02-29 10:27:40 EST
In testing repository for F-8 will be updated perl-5.8.8-35 with the same
version of Scalar::Util as is in cpan. Please let me know, if it's worked for you.

yum --enablerepo=updates-testing install perl
Comment 10 Fedora Update System 2008-03-01 04:27:47 EST
perl-5.8.8-35.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2164
Comment 11 Richard Kennedy 2008-03-03 09:06:42 EST
there is no updated 64 bit perl version in testing, so I couldn't test this, sorry
Comment 12 Marcela Mašláňová 2008-03-06 09:03:14 EST
The package perl-5.8.8-36 upgrade the Scalar::Util on the latest version. The
problem with XS support, weaken and other functions provided by Scalar::Util
should be fixed by this update. 
If you problem persist, please feel free to reopen the bug.
Comment 13 Fedora Update System 2008-03-07 14:52:11 EST
perl-5.8.8-36.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.